jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From laurallew <laural...@yahoo.com>
Subject did the apparent race condition ever get fixed?
Date Fri, 11 Jul 2003 20:32:48 GMT
Hi,

I am running a nightly Cactus build
(jakarta-cactus-13-20030615) with Orion 1.5.2 on Linux
Redhat 8.  I am using j2sdkee1.3.1 and jdk1.3.1_06.  I
run my tests from Ant, version 1.5.2.

At least half the time when I run my tests, I receive
an error like the following:

Testcase: testEmptyFields took 9.121 sec
        Caused an ERROR
Failed to get the test results. This is probably due
to an error that happened on the server side when
trying to execute the tests. Here is what was returned
by the server : [
<!-- ############# start HTML ############### -->
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0
Transitional//EN"
        "http://www.w3.org/TR/REC-html40/loose.dtd">
<html>
<head>

.... more HTML here....
]

When I check my cactus server logs (I saved them if
you need them) I see this:

15:34:11,015 [RMIConnectionThread] DEBUG
rver.AbstractWebTestController  - Service to call =
GET_RESULTS
15:34:11,016 [RMIConnectionThread] DEBUG
server.AbstractWebTestCaller    - Test Result = [null]
15:34:11,080 [RMIConnectionThread] DEBUG
server.AbstractWebTestCaller    - Test result : [Test
ok]
15:34:11,081 [RMIConnectionThread] DEBUG
server.AbstractWebTestCaller    - Result saved in
context scope

On the client side, I see a null pointer exception:
15:34:11,065 [main] DEBUG util.IoUtil                 
   -
<getText([org.apache.commons.httpclient.AutoCloseInputStream@52513a],
[UTF-8])
15:34:11,070 [main] DEBUG util.IoUtil                 
   - >getText = [<HTML><HEAD><TITLE>500 Internal
Server Error</title></head><BODY><H1>500 Internal
Server
Error</h1><PRE>java.lang.NullPointerException<br>
... more here ...

Note the milliseconds and the "Test Result=[null]". 
When the tests run to completion, I never see that
"result=[null]" phrase.

I don't think it's an error in my configuration
because about half the time it runs fine (and I love
it by the way... so much easier than manually typing
data in a browser form!).

Another perhaps related issue.  One of my test cases
included quite a bit of code after it called my
servlet's doGet method.  It performed some assertions
and then reset some database records.  The endTestxxx
method for this case was very short.  I had logging
code in both methods and what I was seeing was the
endTestxxx method running before the testxxx method
had finished.  Then, apparently because the endTestxxx
had completed, the next test case started to execute,
and the server/ant hung; I had to Ctrl-C it.  I
"solved" the problem by moving the database record
reset code into my endTestxxx method and now the tests
run fine.

I have checked the mailing list and the only reference
to this topic are some emails from Frank Baxter and
Brian Murray in October of 2002, reporting similar
issues.  In one of the responses, Vincent said he
would (re)implement a semaphore to prevent this.  Did
that happen?  If so, what else could be causing this
problem?  If the semaphore isn't there yet, are there
any plans to put it back?

Thanks so much.

Laura





__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

Mime
View raw message