jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rajeev....@accenture.com
Subject Cactus: Getting Error org.apache.cactus.util.ChainedRuntimeException: Not a valid response , Pls help
Date Fri, 09 May 2003 09:00:27 GMT
Hi ,
   I am have downloaded the Cactus verion 1.3 and integrated it with  IBM
WSAD version 5.0 . I following exactly the same procedure as mentioned in
the  How-tos for configuration and setting up the class path in the WSAD
env. M aim is to see how a servlet can be tested hence , I copied the
SampleServlet and the TestSampleServlet components  and placed it in the
servlet directory of my web application . After this I started the server ,
went the java perspective and ran the  TestSampleServlet component as a
java application up on which the swing UI poped up . Up till this things
seem to be fine but when the testXXX methods are being called , all  of
them fail , with the error message  " Not a valid response " , the error
trace in the UI runs as follows :

      org.apache.cactus.util.ChainedRuntimeException: Not a valid response
      at
org.apache.cactus.client.WebTestResultParser.readRootElement(LogAspect.java(1k):134)
      at
org.apache.cactus.client.WebTestResultParser.dispatch29_parse(LogAspect.java(1k):101)
      at
org.apache.cactus.client.WebTestResultParser.around29_parse(LogAspect.java(1k):1221)
      at
org.apache.cactus.client.WebTestResultParser.parse(LogAspect.java(1k):96)
      at
org.apache.cactus.client.AbstractHttpClient.callGetResult(LogAspect.java(1k):231)
      at
org.apache.cactus.client.AbstractHttpClient.dispatch1_doTest(LogAspect.java(1k):123)
      at
org.apache.cactus.client.AbstractHttpClient.around1_doTest(LogAspect.java(1k):1221)
      at
org.apache.cactus.client.AbstractHttpClient.doTest(LogAspect.java(1k):115)
      at
org.apache.cactus.AbstractTestCase.runGenericTest(AbstractTestCase.java:457)
      at
org.apache.cactus.ServletTestCase.runTest(ServletTestCase.java:133)
      at
org.apache.cactus.AbstractTestCase.runBare(AbstractTestCase.java:400)

I wonder what else is missing as I have the web.xml , cactus.properties
with correct entries and all the required jars in the classpath . Can some
body please guide me .



----------------------------------------------------------------
Rajeev Pai
Accenture
Mumbai Delivery Centre -2
Direct Dial - 091 022 55984492
AIM ID - lotusPi
------------------------------------------------------------------


This message is for the designated recipient only and may contain
privileged, proprietary, or otherwise private information.  If you have
received it in error, please notify the sender immediately and delete the
original.  Any other use of the email by you is prohibited.


Mime
View raw message