jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anton_Gr...@mn.man.de
Subject Antwort: Re: Please Help: Antwort: RE: Cactus 1.4.1 using WebSphere 5.0
Date Thu, 08 May 2003 10:08:23 GMT

Hello Christopher,

thanks for your response.

Taking your example I tried to request the Redirector (and even a simple
html-page)
using a telnet session with specifying the host-header.

I noticed that the IBMHttpServer answers with a Error400 (Bad Request) to

###
GET /mandeploymantwebapp/upload.html HTTP/1.1
Host: localhost : 8080

HTTP/1.1 400 Bad Request
###

Using the HttpTransport-Port of a Single-Server in my Cluster the same
request works fine,
the same is true for Tomcat 4.1.18.

Contacting IBM-Support I was told that there needn't be any blank between
the
Host-Name and the Port! This is true for IBMHTTPServer.

Now, my questions are:

"Is this a problem for Cactus?"
"Is this correct for RFC2616?"

Thanks for your help.

Toni

---------------------------------------------------------------
Anton Grimm
MAN Nutzfahrzeuge AG
IDP - Software Produktionsumgebungen
Dachauerstr.667
D - 80995 München

Fon:       +49-89-1580-1054
Fax:       +49-89-1580-911054
mailto:    Anton_Grimm@mn.man.de
Internet: http://www.man-trucks.com
---------------------------------------------------------------




                                                                                         
                                             
                      Christopher Lenz                                                   
                                             
                      <cmlenz@gmx.de>          An:       Cactus Users List <cactus-user@jakarta.apache.org>
                           
                                               Kopie:                                    
                                             
                      05/06/2003 09:33         Thema:    Re: Please Help: Antwort: RE: Cactus
1.4.1 using WebSphere 5.0                
                      AM                                                                 
                                             
                      Bitte antworten                                                    
                                             
                      an "Cactus Users                                                   
                                             
                      List"                                                              
                                             
                                                                                         
                                             
                                                                                         
                                             




(I posted a reply via gmane, but that didn't come through obviously;
Vincent, do gmane posts go over the moderation queue?)

Anton_Grimm@mn.man.de wrote:
>
> I did not know that it is no longer possible to simulate
> HTTP-Requests to a HttpServer with version 1.1 of HTTP
> like it was in 1.0 using Telnet (.

It is, you just need to provide a Host header:

$ telnet localhost 8080
GET /ServletRedirector?Cactus_Service=RUN_TEST
Host: localhost

BTW, I could imagine your problem having to do with virtual hosting.
You're using a real host name for Tomcat, but 'localhost' for WebSpere
AFAICT. WebSphere is replying as running on 'mm009436', so maybe the
Cactus context is deployed a virtual host that doesn't match 'localhost'.

> Sorry wasting your time ... but I can't solve this for almost three days
> now.
>
> Anyway the output of the cactus-log is different for running my tests
> against websphere
> in comparison with tomcat.
> Again, I use the same Cactus client configuration for both
Servlet-Engines,
> the same application and the same build file. The important thing for the
> WebSphere-Environment
> is that the URL
>
>
http://localhost:8080/mandeploymantwebapp/ServletRedirector?Cactus_TestMethod=testExecuteDeploymantActionSuccess&

>
Cactus_TestClass=iutest.de.man.mn.pcm.deploymant.struts.action.DeploymantActionTest&Cactus_AutomaticSession=true&Cactus_Service=CALL_TEST

>
> which fails in the junit task succeeds using InternetExplorer 6.0.26 and
> Netscape (empty screen).
> If I request just the RedirectorServlet using the Netscape Browser on the
> WebSPhere machine
>       http://localhost:8080/mandeploymantwebapp/ServletRedirector?
> I receive an error 500 (Error 500: Missing service name parameter
> [Cactus_Service] in HTTP request. Received query string is [null].)
> which should be fine. The junit tasks fails with error 404. Please see
the
> logs below.
>
> The Tomcat-Files:
>
> (See attached file: log4j_cactus.log)
>
> The WebSphere-Files:
>
> (See attached file: log4j_cactus.log)(See attached file: build.log)
>
> ### junit-task ###
>
>     <junit
>       printsummary="yes"
>       haltonfailure="no" failureproperty="test-failed"
>       fork="yes"
>     >
>         <classpath>
>             <!-- The Servlet API jar -->
>             <pathelement location="
> ${global.was.extlib.dir}/JavaJ2ee_r1-3.jar"/>
>
>             <!-- all libraries needed by this project      -->
>             <fileset dir="${global.src.dir}/${web-inf.dir}/lib">
>               <include name="*.jar"/>
>               <include name="*.zip"/>
>             </fileset>
>
>             <!-- all classes of this project               -->
>             <pathelement location="${global.build.dir}"/>
>         </classpath>
>         <formatter type="xml" usefile="true"/>
>
>         <!-- test name="your.package.YourTestCaseClass1"/ -->
>         <jvmarg value="-Dlog4j.configuration=file:
> ${global.dev.dir}/log4j.properties"/>
>         <test
>           name="de.man.mn.sys.test.MANJUnitUnitTest"
>           haltonerror="no"
>           outfile="./doc/UnitTestReport"
>         />
>         <test
>           name="de.man.mn.sys.test.MANJUnitIntegrationTest"
>           haltonerror="no"
>           outfile="./doc/IntegrationTestReport"
>         />
>     </junit>
>
> ###
>
> Thanks so much for any help.
>
> A. Grimm
>
> ---------------------------------------------------------------
> Anton Grimm
> MAN Nutzfahrzeuge AG
> IDP - Software Produktionsumgebungen
> Dachauerstr.667
> D - 80995 München
>
> Fon:       +49-89-1580-1054
> Fax:       +49-89-1580-911054
> mailto:    Anton_Grimm@mn.man.de
> Internet: http://www.man-trucks.com
> ---------------------------------------------------------------
>
>
> This message and any attachments are confidential and may be privileged
or otherwise protected from disclosure.
> If you are not the intended recipient, please telephone or email the
sender and delete this message and any attachment
> from your system. If you are not the intended recipient, you must not
copy this message or attachment or disclose the
> contents to any other person.


--
Christopher Lenz
/=/ cmlenz at gmx.de


---------------------------------------------------------------------
To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: cactus-user-help@jakarta.apache.org






This message and any attachments are confidential and may be privileged or otherwise protected
from disclosure. 
If you are not the intended recipient, please telephone or email the sender and delete this
message and any attachment 
from your system. If you are not the intended recipient, you must not copy this message or
attachment or disclose the 
contents to any other person.


Mime
View raw message