jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Raible" <m...@raibledesigns.com>
Subject Upgrading to Cactus 1.4.1 and StrutTestCase 1.9
Date Tue, 24 Sep 2002 16:57:52 GMT
I'm trying to upgrade to Cactus 1.4.1 and StrutsTest 1.9.  My tests
where working about fine a month ago with nightly builds of both, and I
found that I had to change the following to get it to work with the new
stuff:

cactus.properties from: cactus.contextURL = http://localhost/myApp

To: cactus.contextURL = http://localhost:80/myApp

build.xml from:

    <!--
=================================================================== -->
    <!--            Test the NavigationAction class in Tomcat
-->
    <!--
=================================================================== -->
    <target name="tomcat.navigationAction" depends="deploy"
if="tomcat.home">
        <!-- We suppose our webapp is named "onpoint" -->
        <runservertests testURL="http://localhost/${webapp.name}" 
            startTarget="start.tomcat" 
            stopTarget="stop.tomcat" 
            testTarget="test.navigationAction"/>
    </target>

To:

    <!--
=================================================================== -->
    <!--            Test the NavigationAction class in Tomcat
-->
    <!--
=================================================================== -->
    <target name="tomcat.navigationAction" depends="deploy"
if="tomcat.home">
        <!-- We suppose our webapp is named "onpoint" -->
        <runservertests
testURL="http://localhost:80/${webapp.name}/ServletRedirector?Cactus_Ser
vice=RUN_TEST" 
            startTarget="start.tomcat" 
            stopTarget="stop.tomcat" 
            testTarget="test.navigationAction"/>
    </target>

Is this expected behavior?

Thanks,

Matt



--
To unsubscribe, e-mail:   <mailto:cactus-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:cactus-user-help@jakarta.apache.org>


Mime
View raw message