jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Lightbody" <pligh...@hotmail.com>
Subject Re: [VOTE] Rename clientSetUp() and clientTearDown() in 1.5dev
Date Thu, 01 Aug 2002 17:47:46 GMT
Well, since you put it that way... I see your point. My only concern is
confusion between beginXxx() and begin(), being that one is tied to an
individual test and the other is tied to the test suite, yet they both share
a common name.

-Pat

----- Original Message -----
From: "Vincent Massol" <vmassol@octo.com>
To: "'Cactus Users List'" <cactus-user@jakarta.apache.org>
Cc: "'Patrick Lightbody'" <plightbo@hotmail.com>
Sent: Thursday, August 01, 2002 6:43 PM
Subject: RE: [VOTE] Rename clientSetUp() and clientTearDown() in 1.5dev


>
>
> > -----Original Message-----
> > From: Patrick Lightbody [mailto:plightbo@hotmail.com]
> > Sent: 01 August 2002 11:11
> > To: Cactus Users List
> > Subject: Re: [VOTE] Rename clientSetUp() and clientTearDown() in
> 1.5dev
> >
> > Personally I think clientSetUp and clientTearDown make more sense,
> > assuming
> > they work just like setUp and tearDown (once per test).
>
> ... yes, but Cactus has already extended JUnit by having beginXXX() and
> endXXX() methods that are executed on the client side. In other words,
> Cactus is "Junit-compliant" on the server side but the client side is
> purely Cactus-specific.
>
> As we already have beginXXX() and endXXX(), don't you think it looks
> logical to have begin() and end() being global extensions (before and
> after each test) ?
>
> Thanks
> -Vincent
>
> >
> > -Pat
> >
> > ----- Original Message -----
> > From: "Vincent Massol" <vmassol@octo.com>
> > To: <cactus-dev@jakarta.apache.org>
> > Cc: "'Cactus Users List'" <cactus-user@jakarta.apache.org>
> > Sent: Thursday, August 01, 2002 10:56 AM
> > Subject: [VOTE] Rename clientSetUp() and clientTearDown() in 1.5dev
> >
> >
> > > Hi,
> > >
> > > Charles Massey has proposed on the 15th of July another name for the
> > > clientSetUp() and clientTearDown() methods : begin() and end().
> > >
> > > I think it is a better name than what we have and I propose to make
> the
> > > change to begin() and end(). It is more logical as we already have
> > > beginXXX() and endXXX() methods.
> > >
> > > What do you think ?
> > >
> > > Here is my +1
> > >
> > > Thanks
> > > -Vincent
> > >
> > >
> > > --
> > > To unsubscribe, e-mail:
> > <mailto:cactus-user-unsubscribe@jakarta.apache.org>
> > > For additional commands, e-mail:
> > <mailto:cactus-user-help@jakarta.apache.org>
> > >
> >
> > --
> > To unsubscribe, e-mail:   <mailto:cactus-user-
> > unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail: <mailto:cactus-user-
> > help@jakarta.apache.org>
>

--
To unsubscribe, e-mail:   <mailto:cactus-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:cactus-user-help@jakarta.apache.org>


Mime
View raw message