jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent Massol" <vmas...@octo.com>
Subject RE: Newbie Help with viewing XSL in browser
Date Sun, 25 Aug 2002 14:21:42 GMT
Dave,

> -----Original Message-----
> From: Dave Hoover [mailto:dave@redsquirrel.com]
> Sent: 22 August 2002 14:13
> To: Vincent Massol
> Cc: 'Cactus Users List'
> Subject: RE: Newbie Help with viewing XSL in browser
> 
> Vincent wrote:
> >Hi Dave,
> 
> Hi Vincent!
> 
> >> and was given an error message from IE 5.5.  I did some searching
> >> and found that IE 5.5 doesn't support XSL:
> >
> >oh. I didn't know that. What we could for the next version is add the
> >XSL transformation in the test runner itself so that it will generate
> >HTML that will work for all browsers. As this requires an XML parser
> and
> >an XSLT engine, we would leave that as an option: for example we
would
> >add a "transform=true" parameter on the query string. What do you
think
> >of this?
> 
> I think this would be an excellent idea.  But that's just the opinion
> of a naive newbie.

Ok. I've added it to the todo list :-)

> 
> >> They recommended upgrading to IE 6, so I did.  I tried it again and
> >> received this message:
> >>
> >> The XML page cannot be displayed
> >> Cannot view XML input using XSL style sheet. Please correct the
error
> >> and then click the Refresh button, or try again later.
> >> --------
> >> System does not support the specified encoding.
> >>
> >>
> >> When I view source, it looks like valid XML to me, although I'm no
> >> expert.  What am I doing wrong?
> >
> >Not sure. There was a bug in Cactus 1.4beta where the <xml> tag came
> >after the <xsl> one. This is fixed in the nightly builds and will be
in
> >the 1.4 final (that I need to get out as soon as I find 2 hours ...)
> >
> >Maybe you could send the source from your browser (view source).
> 
> Not sure how well it would survive via email, I posted it here:
> 
> http://www.redsquirreldesign.com/dave/tmp/cactus_output.xml

ok. Sorry for the delay. Apparently there was a bug in Cactus 1.4beta
WRT the generated XML as Cactus was putting the XSL PI before the XML
tag. This has been fixed in Cactus 1.4 final and in Cactus 1.5dev (i.e.
nightly builds).

The easiest for you is simply to download the latest available nightly
build and try with it. It should work fine.

Thanks
-Vincent

> 
> Thanks,
> --Dave
> 
> 
> 
> 
> 
> 
> 
> --
> To unsubscribe, e-mail:   <mailto:cactus-user-
> unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:cactus-user-
> help@jakarta.apache.org>



--
To unsubscribe, e-mail:   <mailto:cactus-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:cactus-user-help@jakarta.apache.org>


Mime
View raw message