jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From laurent.duper...@masq.ca
Subject Re: Runs on Linux but nor on Solaris :-(
Date Wed, 24 Apr 2002 20:40:30 GMT
On 24 Apr, Vincent Massol wrote:
>> not. On Linux, a testURL that says
>> 
>> http://localhost:8080/cactus
>> 
>> has /ServletRedirector?Cactus_Service=RUN_TEST
>> 
>> appended properly to it when the tests are run but it doesn't do the
> same
>> on
>> Solaris. It's kind of a surprising behaviour, I find.
> 
> Not sure what you're saying here ... ! You are the one who specify in
> your Ant script the value for testURL, right ? The runservertests Ant
> task simply takes this value and uses it, as is, to try to connect to
> the server and thus verify if it is alive or not. Thus, there can't be a
> difference in URL between Solaris and Windows ...
> 

What I'm saying is that I'm using the same jar files, ant scripts, cactus
version, cactus.properties files on Solaris as I am on Linux. On linux, a
testUrl with the value http://localhost:8080/cactus works correctly. But on
Solaris, the testUrl *has* to have
/ServletRedirector?Cactus_Service=RUN_TEST in it. I'm not saying it's a bad
thing nor am I criticising. This is just the behaviour I noticed on my
servers. I don't know what the underlying reason is, though.

L

-- 
Laurent Duperval <mailto:laurent.duperval@masq.ca>

BRILLIANT'S OBSERVATION ON MODERN ART:
   Not all our artists are playing a joke on the public.
   Some are genuinely mad.



--
To unsubscribe, e-mail:   <mailto:cactus-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:cactus-user-help@jakarta.apache.org>


Mime
View raw message