jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent Massol" <vmas...@octo.com>
Subject RE: Unknown Host Exception while trying to run Cactus
Date Mon, 08 Apr 2002 22:42:24 GMT
Devasish,

That's normal ... :-) The URL that you're using in cactus.properties is
invalid (this is what the stacktrace says) ... You seem to be using
something like http://localhost:@test.port@/... If you're using @..@ it
probably means you want to use an Ant filter to replace the value with
an Ant property but you seem to have forgotten to perform the
replacement ...

Hope it helps
-Vincent

> -----Original Message-----
> From: devasish sarangi [mailto:devasishsarangi@yahoo.com]
> Sent: 08 April 2002 21:21
> To: cactus-user@jakarta.apache.org
> Subject: Unknown Host Exception while trying to run Cactus
> 
> Hi,
> 
> I am trying to use Cactus with Websphere Studio 4.0
> environment. I configured the classpaths both in the
> client side and in the server side. When I run
> 'TestAll' in the TestRunner, I am getting the
> following exception
> 
> java.net.UnknownHostException: test.port@
> 
> 	at java.net.InetAddress.getAllByName0(Unknown Source)
> 
> 	at java.net.InetAddress.getAllByName0(Unknown Source)
> 
> 	at java.net.InetAddress.getByName(Unknown Source)
> 
> 	at java.net.Socket.<init>(Unknown Source)
> 
> 	at sun.net.NetworkClient.doConnect(Unknown Source)
> 
> 	at sun.net.www.http.HttpClient.openServer(Unknown
> Source)
> 
> 	at sun.net.www.http.HttpClient.openServer(Unknown
> Source)
> 
> 	at sun.net.www.http.HttpClient.<init>(Unknown Source)
> 
> 	at sun.net.www.http.HttpClient.<init>(Unknown Source)
> 
> 	at sun.net.www.http.HttpClient.New(Unknown Source)
> 
> 	at
> sun.net.www.protocol.http.HttpURLConnection.connect(Unknown
> Source)
> 
> 	at
> sun.net.www.protocol.http.HttpURLConnection.getOutputStream(Unknown
> Source)
> 
> 	at
>
org.apache.cactus.client.HttpClientHelper.addParametersUsingPost(HttpCli
en
> tHelper.java:182)
> 
> 	at
>
org.apache.cactus.client.HttpClientHelper.connect(HttpClientHelper.java:
41
> 6)
> 
> 	at
>
org.apache.cactus.client.AbstractHttpClient.doTest(AbstractHttpClient.ja
va
> :129)
> 
> 	at
>
org.apache.cactus.AbstractTestCase.runGenericTest(AbstractTestCase.java:
42
> 2)
> 
> 	at
> org.apache.cactus.ServletTestCase.runTest(ServletTestCase.java:130)
> 
> 	at
> org.apache.cactus.AbstractTestCase.runBare(AbstractTestCase.java:371)
> 
> Seems like a basic setup problem. But I can't figure
> out what. I am able to run the servlet in my Test
> Environment sucessfully.
> 
> If anybody has a clue, please let me know.
> Thanks,
> Devasish
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Tax Center - online filing with TurboTax
> http://taxes.yahoo.com/
> 
> --
> To unsubscribe, e-mail:   <mailto:cactus-user-
> unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:cactus-user-
> help@jakarta.apache.org>
> 




--
To unsubscribe, e-mail:   <mailto:cactus-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:cactus-user-help@jakarta.apache.org>


Mime
View raw message