jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Feng, Tianwen" <tianwen.f...@sapmarkets.com>
Subject RE: Problem while running Cactus sample with Ant - testSendCookie () method
Date Sat, 23 Mar 2002 20:50:02 GMT
Hi,
 
It looks like you don't have the log4j.jar file in your Cactus lib
directory.  If you do have that jar file, make sure the jar file contains
the org.apache.log4j.Level class.  If you do not have that class in your
log4j.jar file, you need to get the right version of the file.
 
Regards,
Tim
 
-----Original Message-----
From: Luis M. Rosso [mailto:lrosso@up2u.com.ar]
Sent: Saturday, March 23, 2002 10:51 AM
To: Cactus Users List
Subject: Problem while running Cactus sample with Ant - testSendCookie()
method


Hi, while runnig with Ant the sample included in the Cactus distribution
(ant tests_all), I get 10 tests run and 0 failures, but also the following
error, in the testSendCookie method:
 
[junit] TestCase: testSendCookie took 0.431 sec
[junit]    Caused an ERROR
[junit] org/apache/log4j/Level
java.lang.NoClassDefFoundError: org/apache/log4j/Level
 at
org.apache.commons.httpclient.log.LogSource.makeNewLogInstance(LogSource.jav
a:143)
 at
org.apache.commons.httpclient.log.LogSource.getInstance(LogSource.java:94)
 at org.apache.commons.httpclient.Cookie.<clinit>(Cookie.java:1096)
 at
org.apache.cactus.client.HttpClientHelper.addCookies(HttpClientHelper.java:2
52)
 at
org.apache.cactus.client.HttpClientHelper.connect(HttpClientHelper.java:412)
 at
org.apache.cactus.client.AbstractHttpClient.doTest(AbstractHttpClient.java:1
29)
 at
org.apache.cactus.AbstractTestCase.runGenericTest(AbstractTestCase.java:422)
 at org.apache.cactus.ServletTestCase.runTest(ServletTestCase.java:130)
 at org.apache.cactus.AbstractTestCase.runBare(AbstractTestCase.java:371)
 at junit.framework.TestResult$1.protect(TestResult.java:106)
 at junit.framework.TestResult.runProtected(TestResult.java:124)
 at junit.framework.TestResult.run(TestResult.java:109)
 at junit.framework.TestCase.run(TestCase.java:131)
 at junit.framework.TestSuite.runTest(TestSuite.java:173)
 at junit.framework.TestSuite.run(TestSuite.java:168)
 at junit.framework.TestSuite.runTest(TestSuite.java:173)
 at junit.framework.TestSuite.run(TestSuite.java:168)
 at
org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.run(JUnitTestRu
nner.java:231)
 at
org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.main(JUnitTestR
unner.java:409)

I have not found similar questions in the mailing list archive.
 
I have attached the client and server logs.
 
I am running Cactus 1.2 for Servlet 2.3 with Tomcat 4 and the "prepackaged"
version of Ant.
 
Does someone know what I am doing wrong, and what I should do in order to
get all these tests work?
 
Thanks in advance
 
Luis

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message