jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ray Tayek <rta...@earthlink.net>
Subject RE: newbie, 1.4 fails on assertion, 1.3 says no jaxp, then no javax.servlet
Date Sun, 10 Feb 2002 22:17:14 GMT
At 02:55 PM 2/9/02 +0000, you wrote:
>... 1/ Cactus was not supporting the JDK 1.4 until now .... It now works
>fine with it. You'll need to grab the nightly dated 10th of February.

great! (i got tomcat to work by restricting he size of the stack - rtfm! 
it's in the release notes).

>2/ You need servlet.jar if you're unit testing
>servlets/jsp/filters/taglibs and j2ee.jar if you're unit testing EJBs
>(or your application server jars).

i am using the one in tomcat. the jar. i will try the new cactus rsn. my 
current version is getting much further now - it runs a bunch of tests (41) 
and fails on the last

thanks

>-Vincent
>
> > -----Original Message-----
> > From: Ray Tayek [mailto:rtayek@mediaone.net]
> > Sent: 06 February 2002 20:54
> > To: Cactus Users List
> > Subject: RE: newbie, 1.4 fails on assertion, 1.3 says no jaxp, then no
> > javax.servlet
> >
> > At 08:24 PM 2/6/02 +0000, you wrote:
> > >Err ... Let me try to understand  ....
> >
> > sorry to be so obscure.
> >
> > >- What's 1.4 ? Apparently it's a version but of what ? Ant ?
> >
> > jdk1.4 (has assertions).
> >
> > >- What assertion call ?
> >
> > any of them (first is in TestServletTestCase2.java line 135)
> >
> > >- What's anthole ? (ant_home/lib ?)
> >
> > yes
> >
> > >- What are you compiling ? Cactus ? Your application ?
> >
> >   typing ant to make the sample.
> >
> > >- Is the Servlet API jar in your classpath ?
> >
> > not sure now (i am trying java 1.3). i think it was when i was using
> > jdk1.4
> >
> > >- j2sdk ? What are you trying to test ?
> > >
> > >Your problem looks very much like an Ant issue but I need more
>details
> > >to help you.
> >
> > i tried to build the sample project that came with cactus and ran into
>the
> > assertions using jdk 1.4, so i switched to the jdk 1.3. but 1.3 gave
>me a
> > no compliant jaxp, so i added it and then got the no javax.servlet.
> >
> > it occurs to me that these jdk's are the standard jdk's. maybe i need
>the
> > j2ee jdk's?
> >
> > thanks
> >
> > > > -----Original Message-----
> > > > From: Ray Tayek [mailto:rtayek@mediaone.net]
> > > > Sent: 06 February 2002 18:57
> > > > To: cactus-user@jakarta.apache.org
> > > > Subject: newbie, 1.4 fails on assertion, 1.3 says no jaxp, then no
> > > > javax.servlet
> > > >
> > > > hi, i get errors on the assertion calls in 1.4, but 1.3 says can't
> > >find
> > > > compliant jaxp, so i put crimson in the anthole.
> > > >
> > > > now the compile step says can not find javax.servlet. am i going
>down
> > >the
> > > > wrong path here? i am using j2sdk, not j2ee, is this the problem?
> > > >
> > > > thanks...
> >
> > ---
> > ray tayek http://home.earthlink.net/~rtayek/
> > actively seeking telecommuting work
> > orange county java users group http://www.ocjug.org/
> > hate spam? http://samspade.org/ssw/
> >
> >
> > --
> > To unsubscribe, e-mail:   <mailto:cactus-user-> 
> unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail: <mailto:cactus-user-> 
> help@jakarta.apache.org>
> >
>
>
>
>
>--
>To unsubscribe, e-mail:   <mailto:cactus-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:cactus-user-help@jakarta.apache.org>

---
ray tayek http://home.earthlink.net/~rtayek/
actively seeking telecommuting work
orange county java users group http://www.ocjug.org/
hate spam? http://samspade.org/ssw/


--
To unsubscribe, e-mail:   <mailto:cactus-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:cactus-user-help@jakarta.apache.org>


Mime
View raw message