jakarta-bsf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Gump build uses JDK6, we need JDK5 for 3.x
Date Sat, 03 Apr 2010 15:14:31 GMT
On 03/04/2010, Brett Randall <javabrett@gmail.com> wrote:
> Hi,
>
>  There's currently an issue with unit tests when building the 3.x
>  branch with JDK6 - unit tests fail under Maven.  This is now visible
>  on the Gump build since other build issues allowed the tests to be
>  reached.  The test failure is probably to do with the JDK6 bundled
>  version of Rhino/JavaScript classes obscuring the ones on our test
>  classpath.
>
>  What's the correct fix here - is there an option to ask Gump to build
>  BSF with JDK5, or do we need to work on getting the tests to pass with
>  JDK6?

I think the latter - Gump is about building with the latest versions
of everything.

Besides, developers are likely to be using JDK6 too.

So long as any changes don't affect running with earlier JDKs.

Hudson and Continuum can be used for builds targetted at specific
versions of Java.

>  Brett
>
>  ---------------------------------------------------------------------
>  To unsubscribe, e-mail: bsf-dev-unsubscribe@jakarta.apache.org
>  For additional commands, e-mail: bsf-dev-help@jakarta.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: bsf-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: bsf-dev-help@jakarta.apache.org


Mime
View raw message