jakarta-bsf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject BSF 3.0 beta3 - many tests are skipped, but why?
Date Wed, 29 Jul 2009 16:50:53 GMT
While trying (and failing) to get a new test for Jexl running, I've
just noticed that only 4 of the existing tests are running: e4x,
e4x-1.6r7, jython 2.2, python. The other tests say (for example):

[INFO] [surefire:test]
[INFO] Surefire report directory:
D:\Downloads\bsf-3.0-beta3-src-zip\bsf-3.0-beta3-src\testing\jruby-1.2.0\target\surefire-reports

-------------------------------------------------------
 T E S T S
-------------------------------------------------------
There are no tests to run.

Results :

Tests run: 0, Failures: 0, Errors: 0, Skipped: 0

I've tried updating Surefire to 2.4.3, but it makes no difference.

Any idea why these tests are not running?

I've tried turning on debugging, and compared a test that works with
one that doesn't, but apart from the test names, there does not seem
to be any obvious difference between the ones that work and the ones
that don't.

---------------------------------------------------------------------
To unsubscribe, e-mail: bsf-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: bsf-dev-help@jakarta.apache.org


Mime
View raw message