jakarta-alexandria-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Donie <sdo...@zycor.lgc.com>
Subject RE: getting started
Date Mon, 19 Feb 2001 16:24:33 GMT
I am getting closer. Turned out one of my major problems was in my xml files
- I was getting errors from CVS saying access was denied to a repository,
when in fact the problem was that the repository I was asking for didn't
exist. My CVSROOT was set to 
'/net/houfiler02/vol/vol2/cvs', 
when it should have been
'/net/houfiler02/vol/vol2/cvs/tahoe'

Very frustrating finding that one.

Now when I run alexandria.bat, it hangs during the ChangeLog task. I suspect
the task is getting stuck in some sort of state-machine loop, and I've been
adding println's to the code to see if that is indeed the case or not. Need
to work on that (in addition to my real work) more today. 

Steve

-----Original Message-----
From: Nick Chalko [mailto:Nick@planetU.com]
Sent: Friday, February 16, 2001 4:06 PM
To: 'Steve Donie'; 'Jeff Martin'
Cc: Alexandria Users (E-mail)
Subject: RE: getting started


Did you ever get this to work on NT.

-----Original Message-----
From: Steve Donie [mailto:sdonie@zycor.lgc.com]
Sent: Wednesday, February 07, 2001 9:32 AM
To: 'Jeff Martin'
Cc: Alexandria Users (E-mail)
Subject: RE: getting started


Thanks Jeff - I have gotten the current sources as of yesterday afternoon. I
was able to successfully build alexandria, but now I am getting some errors
when I run alexandria.bat

I have set it up to use Ant 1.3 b1 - perhaps that isn't supported? Anyways,
here is my global.xml:
<cvs>

  <repository type="CVS" opensource="false">

    <name>Tahoe</name>
    <root>/net/houfiler02/vol/vol2/cvs</root>
    <home>http://lonestar</home>
        
    <module>

      <name>Tahoe</name>
      <description>The tahoe project description</description>
      <home>http://lonestar</home>
      <module>tahoe</module>
      <javasrc>src/main</javasrc>
      <revision tag="HEAD" latest="true"/>

      <build buildfile="build.xml" target="build" classpath="lib/mylib.jar">
        <arg name="build.dir" value="./build" />
      </build>

      <test testfile="test.xml" target="test" classpath="lib/mylib.jar">
        <arg name="test.dir" value="./test" />
      </test>
    </module>
        
  </repository>    

</cvs>

And here is the error I get:
E:\Work\open\jakarta-alexandria\build\alexandria>alexandria
Buildfile: .\xml\alexandria.xml

lock:

merge:
     [echo] Generating definition file
   [xstyle] Loading stylesheet
E:\Work\open\jakarta-alexandria\build\alexandria\xsl\merge.xsl

menus:
     [echo] Copying file from src/content to ./content
   [xstyle] Loading stylesheet
E:\Work\open\jakarta-alexandria\build\alexandria\xsl\nav-page.xsl

BUILD FAILED

E:\Work\open\jakarta-alexandria\build\alexandria\var\nav-page.xml:6:
Document root element is missing.

Total time: 1 second
E:\Work\open\jakarta-alexandria\build\alexandria>

When I look at
E:\Work\open\jakarta-alexandria\build\alexandria\var\nav-page.xml, This is
what I get:
<?xml version="1.0" encoding="UTF-8"?>


  

    Tahoe
    /net/houfiler02/vol/vol2/cvs
    http://lonestar
        
    

      Tahoe
      The tahoe project description
      http://lonestar
      tahoe
      src/main
      
Strange, because it looks like none of the XML tags are there, but the
content is...

As you might guess, I am running this on NT.

Thanks for any help - I am excited about getting this working, and
contributing what I can to the project. Until then, though, I'll probably be
asking lots of annoying questions. 

Steve

---------------------------------------------------------------------
To unsubscribe, e-mail: alexandria-users-unsubscribe@jakarta.apache.org
For additional commands, e-mail: alexandria-users-help@jakarta.apache.org

Mime
View raw message