jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Berryman <eric.berry...@gmail.com>
Subject flush to database?
Date Fri, 01 Jun 2018 17:29:46 GMT
Hello!

I have an application that uses jackrabbit to save images, using the
database filestore.
I have jackrabbit clustered (node1, node2).
This was working for me fine, but I started seeing an oddity.
Node1 inserts an image, but node2 doesn't seem to see it when queried
anymore.
So, node2 is now missing about the last 2 weeks of images.
I can see the correct image as a blob in the jcr_ds_DATASTORE table.

And, node2 logged that the journal has been applied.
The LOCAL_REVISIONS table shows both nodes have a revision id of 605
(although I do have 1364 images).

I've tried adding enableConsistencyCheck=true and
forceConsistencyCheck=true to the index part of the repository.xml file.
But, I don't see any errors.  Just, that the consistency check happened.

I've also tried clearing the index directory of node2.  Jackrabbit
recreates the index, applies the 605 journal entries, then ends up in the
same state without the last two weeks of images.

Are there any ideas to fix what seems to be an index issue.

Any help or ideas to troubleshoot are greatly appreciated.
(jackrabbit 2.6)

Thank you!
Eric

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message