jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Cohen <oleg.co...@assurebridge.com>
Subject Running Oak 1.8.2 in an OSGi container
Date Tue, 13 Feb 2018 03:09:42 GMT
Greetings,

I wonder if anybody had luck deploying 1.8.2 into an OSGi container like Karaf?

I have tried and I am getting multiple missing requirement errors.

For example:

caused by: Unable to resolve org.apache.jackrabbit.oak-core/1.8.2: missing requirement [org.apache.jackrabbit.oak-core/1.8.2]
osgi.service; filter:="(objectClass=org.apache.jackrabbit.oak.spi.mount.MountInfoProvider)";
effective:=active

I followed this: https://github.com/apache/sling-org-apache-sling-karaf-features/tree/feature/oak-1.8
<https://github.com/apache/sling-org-apache-sling-karaf-features/tree/feature/oak-1.8>
as an example, but no luck.

Would appreciate any info on this.

Thank you,
Oleg
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message