jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clay Ferguson <wcl...@gmail.com>
Subject Re: Jackrabbit Deployment problem in Tomcat 8
Date Fri, 07 Aug 2015 14:25:26 GMT
Well, I'm not using jackrabbit webapp because my app is based on SpringBoot
(see meta64.com and on github), but I can tell you two tips: 1) Look into
the web.xml to see where servlets are being configured, and 2) don't try to
use jackrabbit without getting the latest stable version (v 1.2.3) and
downloading all the source and building on your machine.Then just search
the code for that error message and see what triggers it. Jackrabbit is not
something you can use just based on their docs. You really have to dig into
the code, to learn it unfortunately, but others on this email list will
help out. Check into those things and get back to us.

Best regards,
Clay Ferguson
wclayf@gmail.com
214-957-5950

On Fri, Aug 7, 2015 at 6:56 AM, SAMPUBLIC <Gangadasu.Reddy@fisglobal.com>
wrote:

> I am using jackrabbit-webapp-2.10.1...
>
> The Stack trace is as below:
>
> javax.servlet.ServletException: Only one repository startup servlet allowed
> per web-app.
>
>
> org.apache.jackrabbit.j2ee.RepositoryStartupServlet.init(RepositoryStartupServlet.java:226)
>         javax.servlet.GenericServlet.init(GenericServlet.java:158)
>
>
> org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:501)
>
>
> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:79)
>
>
> org.apache.catalina.valves.AbstractAccessLogValve.invoke(AbstractAccessLogValve.java:610)
>
> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:516)
>
>
> org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1086)
>
>
> org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:659)
>
>
> org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:285)
>
>
> org.apache.tomcat.util.net.AprEndpoint$SocketProcessor.doRun(AprEndpoint.java:2439)
>
>
> org.apache.tomcat.util.net.AprEndpoint$SocketProcessor.run(AprEndpoint.java:2428)
>
>
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
>
>
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
>
>
> org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
>         java.lang.Thread.run(Thread.java:744)
>
>
>
> --
> View this message in context:
> http://jackrabbit.510166.n4.nabble.com/Jackrabbit-Deployment-problem-in-Tomcat-8-tp4662670p4662787.html
> Sent from the Jackrabbit - Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message