jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frederic Gilbart <fgilb...@capsiel.fr>
Subject RE: Jackrabbit Deployment problem in Tomcat 8
Date Tue, 11 Aug 2015 18:24:48 GMT
Hi,

I had the same trouble few month ago. So far I can remember, it seems to have issue with tomcat
8
getServletContext().getResourceAsStream 
which returns bad thing when path start (or not.. I can't remember) with "/". Then jackrabbit
jsp error page hides information.

Had no other solution than using a local RepositoryStartupServlet to make it work: try adding
a catch around 

InputStream in = getServletContext().getResourceAsStream(repConfig);

In the RepositoryStartupServlet .java private void initRepository() throws ServletException
method to get more log.

Hope that helps.

No more using this so I don't have full code now. 

Fred


-----Message d'origine-----
De : Reddy, Gangadasu S [mailto:Gangadasu.Reddy@fisglobal.com] 
Envoyé : mercredi 22 juillet 2015 13:00
À : dev@jackrabbit.apache.org.html; users@jackrabbit.apache.org
Objet : Jackrabbit Deployment problem in Tomcat 8

Hi,

I am recently had to use jackrabbit. I was able to deploy the JackRabbit WAR
file in Tomcat 7. However I am not able to deploy in Tomcat 8, because it is
throwing an error saying only one repository can be configured. I did double
check, I am using only one repository in  Tomcat 8.
Is this a Known issue? Is there any workaround for this.

Regards,
GSR

_____________
The information contained in this message is proprietary and/or
confidential. If you are not the intended recipient, please: (i) delete the
message and all copies; (ii) do not disclose, distribute or use the message
in any manner; and (iii) notify the sender immediately. In addition, please
be aware that any message addressed to our domain is subject to archiving
and review by persons other than the intended recipient. Thank you.

Mime
View raw message