jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Harrison <peter.harri...@team.orcon.net.nz>
Subject Re: Connecting to a remote repository
Date Wed, 12 Mar 2014 02:47:39 GMT
I found the solution to my problem. The bootstrap.properties file that 
is used to configure among other things the location of the repository 
also can specify the rmi.host.

If there is a rmi.host entry in this configuration it is used. On the 
other hand if it is not present the binding will be to all interfaces.

On 12/03/14 15:30, Peter Harrison wrote:
> Thanks for the reply Robert,
>
> On the server the hostname was set to 127.0.0.1 in the hosts file, and 
> so this IP was sent when the client tried to connect. I have resolved 
> this by changing it in the hosts file.
>
> The problem now is that port 1099 is being opened for RMI on the 
> server bound to 127.0.0.1. This means it will not accept any incoming 
> remote connections.
>
> I have tried to set the binding by setting the tomcat startup 
> parameters like so:
> export CATALINA_OPTS="-Djava.rmi.server.hostname=myserver.com"
> But port 1099 still binds to 127.0.0.1.
>
> I have seen references to making config changes inside web.conf to 
> alter the RMI port, but none have supplied any details of what the 
> configuration would look like.
>
> I also tried using Webdav, but there is apparently a problem that 
> because the authentication details are not provided when setting up 
> the Repository it declines using it as a repository connection. I have 
> seen no work around for this, which on the face of it appears to 
> indicate that Webdav is not a functioning way of remote connection.
>
> Which leaves RMI - and these binding issues.


Mime
View raw message