jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Harrison <peter.harri...@team.orcon.net.nz>
Subject Re: Connecting to a remote repository
Date Wed, 12 Mar 2014 02:30:22 GMT
Thanks for the reply Robert,

On the server the hostname was set to 127.0.0.1 in the hosts file, and 
so this IP was sent when the client tried to connect. I have resolved 
this by changing it in the hosts file.

The problem now is that port 1099 is being opened for RMI on the server 
bound to 127.0.0.1. This means it will not accept any incoming remote 
connections.

I have tried to set the binding by setting the tomcat startup parameters 
like so:
export CATALINA_OPTS="-Djava.rmi.server.hostname=myserver.com"
But port 1099 still binds to 127.0.0.1.

I have seen references to making config changes inside web.conf to alter 
the RMI port, but none have supplied any details of what the 
configuration would look like.

I also tried using Webdav, but there is apparently a problem that 
because the authentication details are not provided when setting up the 
Repository it declines using it as a repository connection. I have seen 
no work around for this, which on the face of it appears to indicate 
that Webdav is not a functioning way of remote connection.

Which leaves RMI - and these binding issues.

On 12/03/14 08:59, Robert Munteanu wrote:
> On Mar 11, 2014 9:47 PM, "Peter Harrison" <peter.harrison@team.orcon.net.nz>
> wrote:
>> I'm having huge trouble connecting to a remote JackRabbit instance.
>>
>> In development I have been deploying to the same Tomcat instance and
> using a localhost URL to connect, aka:
>> http://localhost:8080/jackrabbit-webapp-2.6.5/rmi
>> I can use JackRabbitExplorer to log into this URL on the local system
> with not trouble at all.
>>
>> However, if I use a URL to another machine set up in an identical way,
> aka:
>> http://testserver.com:8080/jackrabbit-webapp-2.6.5/rmi
>>
>> Then I get:
>> "There was an error logging in:
> com.priocept.jcr.client.SerializedException: java.rmi.ConnectException:
> Connection refused to host: 127.0.1.1; nested exception is:
> java.net.ConnectException: Connection refused"
>
> This is a RMI issue. Make sure that the host name of the machine running
> Jackrabbit resolves to an IP which is accessible from other machines.
>
> On Linux machines this would be done by editing /etc/hosts
>
> Robert
>> Now, if you set up JackRabbitExplorer on the remote machine and use the
> first 'localhost' URL it will connect.
>> It looks like the call to the URL is providing the client with details of
> an RMI server and port, but the server is 'localhost' - and so it fails. I
> think.
>> I certainly do not want to have my Jackrabbit tomcat instances also
> running my tomcat application. I need to be able to connect to a remote
> Jackrabbit instance.
>> I have also tried using Webdavex, using the /server URL, but this is even
> less successful.
>> How do others connect to a remote JackRabbit repository?
>>
>>
>


Mime
View raw message