jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marek Slama" <msl...@email.cz>
Subject Re: Migrate from 2.4.4 to 2.6.4: Unknown format version: -11
Date Sat, 23 Nov 2013 09:34:49 GMT
Is it possible that you have multiple Lucene versions on classpath?

Marek



---------- Původní zpráva ----------
Od: Robert Haycock <Robert.Haycock@artificial-solutions.com>
Datum: 22. 11. 2013
Předmět: Migrate from 2.4.4 to 2.6.4: Unknown format version: -11

"Hi,

I just updated to version 2.6.4, from 2.4.4, and I periodically encounter 
this problem when starting my app (running in tomcat).

2013-11-22 09:09:58,451 ERROR [Thread-2] [] (RepositoryImpl.java:524) - 
Failed to initialize workspace 'default'
javax.jcr.RepositoryException: Unable to initialize query handler: com.
artisol.teneobackend.search.TeneoSearchIndex@651f684
at org.apache.jackrabbit.core.config.RepositoryConfigurationParser$1.
getQueryHandler(RepositoryConfigurationParser.java:658)
at org.apache.jackrabbit.core.config.WorkspaceConfig.getQueryHandler
(WorkspaceConfig.java:251)
at org.apache.jackrabbit.core.SearchManager.<init>(SearchManager.java:171)
at org.apache.jackrabbit.core.RepositoryImpl$WorkspaceInfo.getSearchManager
(RepositoryImpl.java:1862)
at org.apache.jackrabbit.core.RepositoryImpl$WorkspaceInfo.doPostInitialize
(RepositoryImpl.java:2098)
at org.apache.jackrabbit.core.RepositoryImpl$WorkspaceInfo.initialize
(RepositoryImpl.java:2004)
at org.apache.jackrabbit.core.RepositoryImpl.initStartupWorkspaces
(RepositoryImpl.java:517)
at org.apache.jackrabbit.core.RepositoryImpl.<init>(RepositoryImpl.java:324)
at com.artisol.teneobackend.jackrabbit.TeneoRepositoryImpl.<init>
(TeneoRepositoryImpl.java:17)
at com.artisol.teneobackend.context.ContextListener.initialiseRepository
(ContextListener.java:119)
at com.artisol.teneobackend.context.ContextListener.access$3
(ContextListener.java:100)
at com.artisol.teneobackend.context.ContextListener$Initialisation.run
(ContextListener.java:229)
at java.lang.Thread.run(Thread.java:662)
Caused by: org.apache.lucene.index.CorruptIndexException: Unknown format 
version: -11
at org.apache.lucene.index.SegmentInfos.read(SegmentInfos.java:249)
at org.apache.lucene.index.DirectoryReader$1.doBody(DirectoryReader.java:77)
at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.
java:677)
at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:73)
at org.apache.lucene.index.IndexReader.open(IndexReader.java:316)
at org.apache.lucene.index.IndexReader.open(IndexReader.java:262)
at org.apache.jackrabbit.core.query.lucene.AbstractIndex.getIndexReader
(AbstractIndex.java:255)
at org.apache.jackrabbit.core.query.lucene.AbstractIndex.
getReadOnlyIndexReader(AbstractIndex.java:286)
at org.apache.jackrabbit.core.query.lucene.AbstractIndex.
getReadOnlyIndexReader(AbstractIndex.java:340)
at org.apache.jackrabbit.core.query.lucene.IndexMigration.migrate
(IndexMigration.java:76)
at org.apache.jackrabbit.core.query.lucene.PersistentIndex.<init>
(PersistentIndex.java:82)
at org.apache.jackrabbit.core.query.lucene.MultiIndex.<init>(MultiIndex.
java:286)
at org.apache.jackrabbit.core.query.lucene.SearchIndex.doInit(SearchIndex.
java:563)
at org.apache.jackrabbit.core.query.AbstractQueryHandler.init
(AbstractQueryHandler.java:78)
at org.apache.jackrabbit.core.config.RepositoryConfigurationParser$1.
getQueryHandler(RepositoryConfigurationParser.java:655)
... 12 more
When it happens I delete the workspaces folder and start again so I get a 
fresh index. This works until the problem eventually comes back.

I haven't yet identified the sequence of events that leads up to this 
problem and I'm not doing anything different to what I did when I was on 
2.4.4. I don't do anything with the workspace/index outside of using the 
jackrabbit API.

Any help much appreciated :)"
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message