jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juan Pardo Invernón <j...@bleep.com>
Subject Repository not available after accessing from a newer version
Date Fri, 09 Aug 2013 12:32:46 GMT
Hi all,

I'm very new to both the list and JAckrabbit, so please throw me some light
here!

I've got a web application that uses Jackrabbit 1.6.4.

The problem is that I used the standalone 2.6.3 version of Jackrabbit to
access the repository and since then the old web application cannot access
the repository anymore.

The database is not corrupted as I can browse it through the standalone app
with no problem at all.

The error I get in the logs is:

BundleDbPersistenceManager: failed to read bundle:
> deadbeef-cafe-babe-cafe-babecafebabe: java.lang.IllegalArgumentException:
> Invalid namespace index: 1231614 (BundleDbPersistenceManager.java, line
> 1209)

RepositoryImpl: Failed to initialize workspace 'default'
> (RepositoryImpl.java, line 496)

javax.jcr.ItemNotFoundException: failed to build path of
> deadbeef-cafe-babe-cafe-babecafebabe: deadbeef-cafe-babe-cafe-babecafebabe:
> deadbeef-cafe-babe-cafe-babecafebabe

        at
> org.apache.jackrabbit.core.HierarchyManagerImpl.getPath(HierarchyManagerImpl.java:398)

        at
> org.apache.jackrabbit.core.SearchManager.<init>(SearchManager.java:209)

        at
> org.apache.jackrabbit.core.RepositoryImpl$WorkspaceInfo.getSearchManager(RepositoryImpl.java:1790)

        at
> org.apache.jackrabbit.core.RepositoryImpl$WorkspaceInfo.doPostInitialize(RepositoryImpl.java:2008)

        at
> org.apache.jackrabbit.core.RepositoryImpl$WorkspaceInfo.initialize(RepositoryImpl.java:1921)

        at
> org.apache.jackrabbit.core.RepositoryImpl.initStartupWorkspaces(RepositoryImpl.java:489)

        at
> org.apache.jackrabbit.core.RepositoryImpl.<init>(RepositoryImpl.java:330)

        at
> org.apache.jackrabbit.core.RepositoryImpl.create(RepositoryImpl.java:627)

        at
> org.apache.jackrabbit.core.jndi.BindableRepository.createRepository(BindableRepository.java:141)

        at
> org.apache.jackrabbit.core.jndi.BindableRepository.init(BindableRepository.java:117)

        at
> org.apache.jackrabbit.core.jndi.BindableRepository.<init>(BindableRepository.java:106)

        at
> org.apache.jackrabbit.core.jndi.BindableRepositoryFactory.getObjectInstance(BindableRepositoryFactory.java:51)

        at
> org.apache.naming.factory.ResourceFactory.getObjectInstance(ResourceFactory.java:140)



If I try to access the database with the standalone 1.6.4 version of
Jackrabbit it is not accessible, but I get a different error:

IllegalStateException: The repository is not available.


I also noticed that after updating the web app libraries to the last
Jackrabbit version a new node appeared as a child of the root node:
"rep:policy".

As there are other systems that also use the database I would like to make
it work on version 1.6.4 again.

Is it possible?


Thanks in advance!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message