jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Klimetschek <aklim...@adobe.com>
Subject Re: Jackrabbit conflict
Date Fri, 12 Jul 2013 12:20:12 GMT
Jackrabbit always depends on a very specific Lucene version, for 2.6.2 that would be Lucene
3.6.0 (that's specified in the jackrabbit parent pom [0] found via mvnrepository.com search,
with the same version as the jackrabbit-standalone release). A newer version usually does
not work, especially not between Lucene 3.x and 4.x which have major API differences.

So the only safe way is to shield it off and have Jackrabbit use its own Lucene version.

[0] http://repo1.maven.org/maven2/org/apache/jackrabbit/jackrabbit-parent/2.6.2/jackrabbit-parent-2.6.2.pom
[1] http://mvnrepository.com/artifact/org.apache.jackrabbit/jackrabbit-parent/2.6.2

Cheers,
Alex

On 09.07.2013, at 22:58, Euler José Ramos <euler.ramos@centralit.com.br> wrote:

> I use jackrabbit-standalone-2.6.2.jar in my Projects and i had conflicts when i used
Lucene-4.3.1, I want to solve this problem, please can you help me?
> 
> Best regards
> EULER JOSÉ RAMOS


Mime
View raw message