jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Menzi <psru...@centrum.cz>
Subject Problem with jboss 5 configuration.
Date Mon, 20 May 2013 08:24:07 GMT
I've encountered a problem with jackrabbit pool in jboss 5 and jackrabbit
2.0. 

I've a jcr datasource configured like this 

 <tx-connection-factory>
    <jndi-name>jcr/local</jndi-name>
    <xa-transaction />
    <track-connection-by-tx>true</track-connection-by-tx>
    <rar-name>jackrabbit-jca.rar</rar-name>
    <connection-definition>javax.jcr.Repository</connection-definition>
    <config-property name="homeDir"
type="java.lang.String">${jackrabbit.homedir}</config-property>
    <config-property name="configFile"
type="java.lang.String">classpath:repository.xml</config-property>
    <config-property name="bindSessionToTransaction"
type="java.lang.Boolean">true</config-property>
    <no-tx-separate-pools />
    <max-pool-size>30</max-pool-size>
</tx-connection-factory>

like this, application works fine, but i'm getting this error really often
(it's thrown every time i'm logging into dms session with this code) 

         Repository repo = (Repository)
ctx.lookup(repository.getJndiName()); 
        Credentials cred = new SimpleCredentials(userId, new char[] { 'p',
'w', 'd' }); 
        Session s = repo.login(cred); 

Destroying connection that could not be successfully matched:
org.jboss.resource.connectionmanager.TxConnectionManager$TxConnectionEventListener@8cd0558[state=NORMAL
mc=org.apache.jackrabbit.jca.JCAManagedConnection@6eec369a handles=0
lastUse=1366642930773 permit=false trackByTx=false
mcp=org.jboss.resource.connectionmanager.JBossManagedConnectionPool$OnePool@8a800c9
context=org.jboss.resource.connectionmanager.InternalManagedConnectionPool@6f7fc42f
xaResource=org.apache.jackrabbit.jca.TransactionBoundXAResource@4c19d8eb
txSync=null] 


when i add to datasource configuration, error mentioned earlier dissapears,
but each connection to jcr creates it's own subpool (which is kinda crazy,
becouse after few hours of application running it creates like 700
subpools). I Tryed searching for possible problems with tag and found out
that it uses ConnectionRequestInfo to authenticate connections but so far
had no success with configuring that. 

Any idea what could i try next to get rid of both problems at once?



--
View this message in context: http://jackrabbit.510166.n4.nabble.com/Problem-with-jboss-5-configuration-tp4658726.html
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.

Mime
View raw message