jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damiano ALBANI <damiano.alb...@gmail.com>
Subject Can't index document data with 2.6.0
Date Tue, 16 Apr 2013 10:22:02 GMT
Hello,

I've just started to play with JackRabbit.
Having launched the 2.6.0 standalone server with the default configuration,
I then run some code to import documents into the repository.
Something as simple as:

    Repository repository = JcrUtils.getRepository("
http://localhost:8080/server");
    Session session = repository.login(new SimpleCredentials("admin",
"admin".toCharArray()));
    File file = new File("/tmp/doc.pdf");
    JcrUtils.putFile(session.getRootNode(), file.getName(),
"application/pdf", new FileInputStream(file));
    session.save();

The file gets added to the repository correctly, I can download it back...
but it doesn't seem to be indexed.
Whatever query I type in the "search.jsp" form, I don't get any result.
Well, except for the "mimeType" field, which seems to be the only one
indexed here.
What am I doing wrong? I've tried with different kinds of documents, always
with the same result.

JackRabbit 2.4.3 and 2.5.3 seem to work just fine with this simple test.
As for 2.6.0, I've noticed that the Lucene index files of the workspace
stay void of any data related to document content!?

Thanks,

-- 
Damiano ALBANI

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message