Hi,

 

I don't think there is support for Sybase ASE, but it's easy to write a own adapter for the database you want to use, because Jackrabbit use a well defined interface:

 

Here are the classes and files we needed to write to support Sybase SQL Anywhere:

 

 

You can look at the existing packages for examples.

 

Regards, Robert

 

-----Ursprüngliche Nachricht-----
Von: Sanjiv [mailto:S.Nagraj@zensar.in]
Gesendet: Dienstag, 19. Februar 2013 10:24
An: users@jackrabbit.apache.org
Betreff: Apache Jackrabbit 2.4.3 support for Sybase ASE 15.7

 

Hi,

 

 

We are developing a business application, which uses Sybase Adaptive Server

15.7  as the database. For storing  content, Apache Jackrabbit 2.4.3 is being used.

 

 

File content ( binary data ) will be stored by  appropriately  configuring DataStore  settings. We would like  to store Node  and Property data through the  Persistence Manager in the Sybase  database.

 

 

Does Apache Jackrabbit 2.4.3 support Sybase  ASE 15.7 ?.  If so, then is it just a matter of configuring the persistence manager in repository.xml accordingly  OR some additional work/effort is required.

 

 

Thanks and Regards,

 

Sanjiv

 

 

 

 



Treffen Sie AEB vom 19.-21. Februar 2013 auf der LogiMAT in Stuttgart. Halle 5, Stand 261.
Vereinbaren Sie jetzt einen Termin und Sie erhalten eine Eintrittskarte.
www.aeb.de/logimat