jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julián Cáceres <jcacere...@gmail.com>
Subject Re: i can't populate the repository with the standalone server
Date Tue, 19 Feb 2013 20:12:33 GMT
I tell you what I have done:
1º download standalone server 2.6 (but with 2.4.3 doesn't work neither)
2º I rename "jackrabbit-standalone-2.6.0.rar" to 
"jackrabbit-standalone-2.6.0.jar" and execute it.
3º I press "populate" and i get the error : "Error while accessing the 
repository: LoginModule ignored Credentials"
4º I edit the "populate.jsp" into the jar, and I change the line "jcrSession 
= rep.login(new SimpleCredentials("user", "".toCharArray()));" to
 "jcrSession = rep.login(new SimpleCredentials("admin", 
"admin".toCharArray()));" I use "admin" because it works with the "browse" 
button.
5º Now, i haven't any error when I press the populate button. I see the web 
page, where I choose the type of the files I want to populate. Now, when I 
press the "populate" button, the web-page with the two progress bar, 
appears, but nothing more happens, the bars don't move from de 0%.
I attach the log files in this mail.


I can't execute the web-app neither. I use tomcat, but I don't know how do 
it. Is there any kind of documentation about this basics? I am doing this 
steps:
1º I execute tomcat in 8086 port.
2º From the application manager, I open the "jackrabbit-webapp-2.6.0.war", 
and I get an "OK" from tomcat.
3º when I try to run the application, Tomcat say something like "I can't run 
the application in the context path /jackrabbit-webapp-2.6.0;
Failed to start component 
[StandardEngine[Catalina].StandardHost[localhost].StandardContext[/jackrabbit-webapp-2.6.0]]

I am completely lost.

thanks, and sorry for my clumsiness

----- Original Message ----- 
From: "Angela Schreiber" <anchela@adobe.com>
To: <users@jackrabbit.apache.org>
Sent: Tuesday, February 19, 2013 6:21 PM
Subject: Re: i can't populate the repository with the standalone server


> hi julián
>
> can you try to find some log output? maybe that can give you (and us)
> some hints on where to look for the issue.
>
> i didn't try that for quite a while but if i remember correctly
> it was sometimes a bit tricky to get the repository properly
> initialized/configured... in case it wasn't the used to be some
> sort of "cannot access repository" message in the logs.
>
> kind regards
> angela
>
> On 2/12/13 11:22 PM, Julián Cáceres wrote:
>> Sorry for my english, I'm spanish.
>> I have execute the standalone server, an i have tried to populate de 
>> repository. When I press de "populate" button, i see a window with two 
>> progress bar, but nothing happens. The web page doesn't do anything. I 
>> have tried with different types and number of documents. I don't Know 
>> what to do.
>> Thanks to someone who can help me. 

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message