jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Angela Schreiber <anch...@adobe.com>
Subject Re: i can't populate the repository with the standalone server
Date Wed, 20 Feb 2013 13:45:38 GMT
hi julián

i had a quick look: the populate.jsp is totally broken.
1) the code still relies on a dummy security setup that would
    allow any kind of credentials to write to the repo... that
    has changed ages ago.
2) i can confirm that changing the populate.jsp to use valid credentials
    doesn't work.

for the time being i would like to suggest that you use the default
webdav access to the repository in order to populate it with files
and folders: http://localhost:8080/repository/default/

i quickly tried it out on my jackrabbit trunk installation and managed
to populate the repository with some content.

if you want know about the actual items created by the webdav server,
you may want to try using the jcr-remoting... there is some basic info
present in the standalone webapp.
for example if you have a node at /test the json serialization of that
node and possible subnodes (2 levels deep) can be viewed at
http://localhost:8080/server/default/jcr:root/test.2.json

sorry for the trouble!
angela

On 2/19/13 9:12 PM, Julián Cáceres wrote:
> I tell you what I have done:
> 1º download standalone server 2.6 (but with 2.4.3 doesn't work neither)
> 2º I rename "jackrabbit-standalone-2.6.0.rar" to
> "jackrabbit-standalone-2.6.0.jar" and execute it.
> 3º I press "populate" and i get the error : "Error while accessing the
> repository: LoginModule ignored Credentials"
> 4º I edit the "populate.jsp" into the jar, and I change the line "jcrSession
> = rep.login(new SimpleCredentials("user", "".toCharArray()));" to
>   "jcrSession = rep.login(new SimpleCredentials("admin",
> "admin".toCharArray()));" I use "admin" because it works with the "browse"
> button.
> 5º Now, i haven't any error when I press the populate button. I see the web
> page, where I choose the type of the files I want to populate. Now, when I
> press the "populate" button, the web-page with the two progress bar,
> appears, but nothing more happens, the bars don't move from de 0%.
> I attach the log files in this mail.
>
>
> I can't execute the web-app neither. I use tomcat, but I don't know how do
> it. Is there any kind of documentation about this basics? I am doing this
> steps:
> 1º I execute tomcat in 8086 port.
> 2º From the application manager, I open the "jackrabbit-webapp-2.6.0.war",
> and I get an "OK" from tomcat.
> 3º when I try to run the application, Tomcat say something like "I can't run
> the application in the context path /jackrabbit-webapp-2.6.0;
> Failed to start component
> [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/jackrabbit-webapp-2.6.0]]
>
> I am completely lost.
>
> thanks, and sorry for my clumsiness
>
> ----- Original Message -----
> From: "Angela Schreiber"<anchela@adobe.com>
> To:<users@jackrabbit.apache.org>
> Sent: Tuesday, February 19, 2013 6:21 PM
> Subject: Re: i can't populate the repository with the standalone server
>
>
>> hi julián
>>
>> can you try to find some log output? maybe that can give you (and us)
>> some hints on where to look for the issue.
>>
>> i didn't try that for quite a while but if i remember correctly
>> it was sometimes a bit tricky to get the repository properly
>> initialized/configured... in case it wasn't the used to be some
>> sort of "cannot access repository" message in the logs.
>>
>> kind regards
>> angela
>>
>> On 2/12/13 11:22 PM, Julián Cáceres wrote:
>>> Sorry for my english, I'm spanish.
>>> I have execute the standalone server, an i have tried to populate de
>>> repository. When I press de "populate" button, i see a window with two
>>> progress bar, but nothing happens. The web page doesn't do anything. I
>>> have tried with different types and number of documents. I don't Know
>>> what to do.
>>> Thanks to someone who can help me.

Mime
View raw message