jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Rigby <sirjas...@gmail.com>
Subject Deploying jackrabbit on Tomcat 7, cannot create repository
Date Fri, 18 Jan 2013 05:15:12 GMT
Hi all,
I'm having some trouble creating a repository using the latest Tomcat
webapp (jackrabbit-webapp-2.2.13.war) on Tomcat 7.0.35.

After deplying the WAR, I specify the location of the new repository in the
"Respository home directory" field, and upon submitting I get "Some error
occurred during setup. See the log files for details."

Catalina.out shows:
2013-01-18 15:54:44.228 INFO  [http-bio-8080-exec-2] Installer.java:149
Creating new repository home '/mnt/lards/jackrabbit'
2013-01-18 15:54:44.242 INFO  [http-bio-8080-exec-2] Installer.java:184
Creating new repository config: /mnt/lards/jackrabbit/repository.xml
2013-01-18 15:54:44.262 INFO  [http-bio-8080-exec-2] Installer.java:208
Creating new bootstrap properties: jackrabbit/bootstrap.properties
2013-01-18 15:54:44.264 ERROR [http-bio-8080-exec-2] Installer.java:172
Error while installing 'jackrabbit/bootstrap.properties':
java.io.FileNotFoundException: jackrabbit/bootstrap.properties (No such
file or directory)

The location where I wanted the repository to be created now contains the
directory and repository.xml file.

Does anyone know how to get this process to complete successfully?

Thanks for your help,

Jason

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message