jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Tuckett <nick.tuck...@playfish.com>
Subject ItemNotFoundException when accessing a changed, unsaved node inside a transaction
Date Tue, 22 Jan 2013 17:20:00 GMT
Hi,

Back in October, I ran into this issue when attempting to access a new node
that had previously been saved but subsequently changed (and the change not
yet saved). This is while updating the repository inside an XA transaction.
I reported this in the Jackrabbit JIRA here:
https://issues.apache.org/jira/browse/JCR-3436 (with a test to reproduce
it).

The issue can be worked around by judicious intermediate session saves, but
that's rather messy and not desirable.

There has been no activity on this issue at all in JIRA, so I thought I
would sound out you folk on the mailing list to see if anyone else has
experienced this, or has any thoughts?

It's starting to bite hard on my application, hence my renewed concern.

Regards

Nick Tuckett.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message