I don't see anywhere where it is claimed that Jackrabbit is ready for OSGi
http://wiki.apache.org/jackrabbit/JackrabbitOsgi is from 2010





From:        XiLai Dai <xldai@talend.com>
To:        "users@jackrabbit.apache.org" <users@jackrabbit.apache.org>
Date:        25/07/2012 12:47 PM
Subject:        RE: Error when install jackrabbit-bundle into OSGi container




Anyone here? If no one give an answer, I will think it as a bug and log a jira issue.

Xilai
-----Original Message-----
From: XiLai Dai [
mailto:xldai@talend.com]
Sent: Friday, July 20, 2012 3:28 PM
To: users@jackrabbit.apache.org
Subject: Error when install jackrabbit-bundle into OSGi container

Hello,

We want to use jackrabbit in the OSGi container (Karaf).  The exception thrown when installed the all-in-one jackrabbit-bundle:

> install -s mvn:org.apache.jackrabbit/jackrabbit-bundle/2.4.2
org.osgi.framework.BundleException: The bundle "org.apache.jackrabbit.jackrabbit-bundle_2.4.2 [219]" could not
be resolved. Reason: Missing Constraint: Import-Package: com.ibm.db2.jcc; version="0.0.0"

why com.ibm.db2.jcc is a mandatory import package?

Thanks in advance
Xilai