jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "De Georges, Adrien" <Adrien.DeGeor...@experian.com>
Subject RE: Error instantiating lucene search index in Turkish Regional Setting
Date Thu, 22 Mar 2012 16:09:03 GMT
Hi again,

We find that this issue is known in java world, due to lower case
conversion of 'I' character. JackRabbit source code try to instantiate
the indexing configuration during the repository starting and is
accessing indexingConfiguration property. It instantiates a setter for
this property with a bad 'i' character.
http://docs.oracle.com/javase/6/docs/api/java/lang/String.html#toLowerCa
se%28java.util.Locale%29
http://mattryall.net/blog/2009/02/the-infamous-turkish-locale-bug
http://nikolajlindberg.blogspot.co.uk/2008/03/beware-of-java-comparing-t
urkish.html

I am about to log an issue on the JackRabbit issue tracker.


-----Original Message-----
From: De Georges, Adrien [mailto:Adrien.DeGeorges@experian.com] 
Sent: 22 March 2012 15:20
To: users@jackrabbit.apache.org
Subject: Error instantiating lucene search index in Turkish Regional
Setting 

Hello guys,

We have a very weird issue when changing regional setting to Turkish. 
It fails when instantiating the lucene search index due to the following
issue :

org.apache.jackrabbit.core.config.ConfigurationException: Configured
class org.apache.jackrabbit.core.query.lucene.SearchIndex does not
contain a property named indexingConfiguration
	at
org.apache.jackrabbit.core.config.BeanConfig.newInstance(BeanConfig.java
:205)
	at
org.apache.jackrabbit.core.config.RepositoryConfigurationParser$1.getQue
ryHandler(RepositoryConfigurationParser.java:631)
	at
org.apache.jackrabbit.core.config.RepositoryConfig.getQueryHandler(Repos
itoryConfig.java:1013)

We have no problem with other language settings. For your information,
here is our configuration :
<SearchIndex
class="org.apache.jackrabbit.core.query.lucene.SearchIndex">
        <param name="path" value="${rep.home}/repository/index"/>
            <param name="indexingConfiguration"
value="conf/indexing_configuration.xml"/>
            <param name="extractorPoolSize" value="2"/>
            <param name="supportHighlighting" value="false"/>
    </SearchIndex>

Does somebody has any idea on this point?
Thanks in advance



Information in this e-mail and any attachments is confidential, and may
not be copied or used by anyone other than the addressee, nor disclosed
to any third party without our permission. There is no intention to
create any legally binding contract or other binding commitment through
the use of this electronic communication unless it is issued in
accordance with the Experian Limited standard terms and conditions of
purchase or other express written agreement between Experian Limited and
the recipient. Although Experian has taken reasonable steps to ensure
that this communication and any attachments are free from computer
virus, you are advised to take your own steps to ensure that they are
actually virus free. 

Companies Act information: Registered name: Experian Limited. Registered
office: Landmark House, Experian Way, NG2 Business Park, Nottingham,
NG80 1ZZ, United Kingdom. Place of registration: England and Wales.
Registered number: 653331


Mime
View raw message