jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CAREMOLI Fran├žois <francois.caremoli.prestata...@sfr.com>
Subject Re: Problem while upgrading from Jackrabbit 1.6.2 to jackrabbit 2.2.9
Date Tue, 13 Dec 2011 11:00:59 GMT
CAREMOLI, Francois (ext. <francois.caremoli.prestataire <at> sfr.com> writes:

> 
> Hello everyone,
> 
>     We were using our Jackrabbit content repository in version 1.6.2 on JBOSS
4.2.3. It was configured as
> described on this page : http://wiki.apache.org/jackrabbit/JackrabbitOnJBoss.
Everything worked
> well, and we decided to upgrade to Jackrabbit v2.2.9. Configuration did not
change, and our content
> repository has behaved correctly, until we led some load testing.
> 
> At this point, the application bugs, and our content repository is no more
available (until a JBOSS
> reboot). The main stack shows this error log :
> 
> 2011-11-29 17:57:17,193 WARN 
[org.apache.jackrabbit.core.session.SessionState] : Attempt to close
> session-username-59 while another thread is concurrently accessing this
session. Blocking until the
> other thread is finished using this session. Please review your code to avoid
concurrent use of a session.



I reply to my post, and think the subject can be closed:

There is one parameter which has been missing in our jcr-ds.xml configuration
file :
<track-connection-by-tx/> 
for our XA transaction. Once we set it, everything ran fine. 

I am not an XA expert, but I think the wiki entry
http://wiki.apache.org/jackrabbit/JackrabbitOnJBoss should be updated to 
reflect the jcr-ds.xml configuration.

Hoping it will help other people getting the same error...


Mime
View raw message