jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jukka Zitting <jukka.zitt...@gmail.com>
Subject Re: Upgrade from 1.6 to 2.x
Date Wed, 28 Dec 2011 16:56:43 GMT
Hi Christopher,

[Please use users@jackrabbit.apache.org directly instead of
users-owner@. Replying on users@]

On Wed, Dec 28, 2011 at 6:16 PM, Christopher Cudennec
<c.cudennec@24technology.de> wrote:
> We're planning to upgrade from Jackrabbit 1.6 to 2.2.x and I would like to
> have your opinion about the upgrade strategy.

You shouldn't need any export/import operations for the upgrade to
2.x, as Jackrabbit 2.x should work fine also with 1.x repositories
(it'll automatically upgrade the things it needs to).

Just make sure you have backups for any unexpected problems that might pop up.

BR,

Jukka Zitting


On Wed, Dec 28, 2011 at 6:16 PM, Christopher Cudennec
<c.cudennec@24technology.de> wrote:
> Hi!
>
>
>
> We're planning to upgrade from Jackrabbit 1.6 to 2.2.x and I would like to
> have your opinion about the upgrade strategy. Unfortunately the Wiki page is
> lacking some information ;) (See:
> http://wiki.apache.org/jackrabbit/BackupAndMigration)
>
>
>
> Can anyone recommend a migration strategy for upgrading from Jackrabbit 1.6
> to 2.x?
>
>
>
> Is there an alternative to export/import? I made a simple test with one of
> our test installations but ran into an OutOfMemoryError during the export.
> Has anyone made experience with huge repositories?
>
>
>
> The RepositoryCopier does not seem to work with newer/older versions of the
> repository, right? I wanted to check it out but ran into a
> ClassNotFoundException because "DerbyPersistenceManager" was moved to
> another package.
>
>
>
> Cheers,
>
>
>
> Christopher

Mime
View raw message