jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gustavo Henrique Orair <gustavo.or...@econoinfo.com.br>
Subject Help disabling Search Manager to resolve conflict between Lucene 3.x and Lucene 2.x versions
Date Sat, 01 Oct 2011 19:11:46 GMT
We are developing a J2EE6 solution where we have an EJB module that depends
directly from Lucene 3.0.3 API.
We've planned to use Jackrabbit just to store a lot of pdf and docs files
and we don't use any Search Manager's features. (we've implemented our own
custom search that uses Lucene 3.x API).

Unfortunatelly, ourr EAR conflicted because Jackrabbit uses Lucene 2.x API:
javax.ejb.TransactionRolledbackLocalException: Exception thrown from bean:
java.lang.NoClassDefFoundError: org/apache/lucene/search/HitCollector

It looks like Jackrabbit will support Lucene 3.x API just in 2.3 version. Is
it correct?
Is there an estimate date to release Jackrabbit 2.3?

Another alternative, could I disable Search Manager and avoid these
conflicts between Lucene 2.x used by Jackrabbit and Lucene 3.x API that we
depend in our own libraries?


Best,
Orair.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message