jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeroen Reijn <j.re...@onehippo.com>
Subject Re: Jackrabbit upgrade from 1.6 to 2.x problem
Date Thu, 27 Oct 2011 20:31:42 GMT
Hi,

On Fri, Oct 14, 2011 at 6:20 PM, Daniel Slack <dslack@langui.com> wrote:
> Hi all,
>
>
>
> For one of our projects, I've decided to upgrade Jackrabbit from 1.6.0 to
> 2.3.0.  I may end up reverting back, just because I am using the RMI
> interface, however, that remains to be seen.  Anyways, from reading the
> documentation, it appears that the RMI interface for 2.0 will only work for
> a "2.0" repository.  So, I was going to use the RepositoryCopier to see if I
> can migrate my repository over.
>
>

yes it's correct that the 2.0 rmi interface is only compatible with a
2.0 repository.

>
> However, when I attempt to create a 2.x Repository instance using my
> existing repository, it fails when attempting to create the version manager.
> When its attempting to check if the Node exists, it throws an exception:
>
>
>
> org.apache.jackrabbit.core.state.ItemStateException: failed to read bundle:
> deadbeef-face-babe-cafe-babecafebabe: java.lang.IllegalArgumentException:
> Invalid namespace index: 6086317
>

Hmm are you sure you have all the correct jars in place? Have you also
tried setting all consistency checks to true?
Are you running jackrabbit in a cluster or as a single instance?

>
>
> I'm not really sure why this is the case, as I assumed the repository was
> backwards compatible between 1.6 and 2.x.  Is there something I'm missing?
>

yes it should be backwards compatible. I've upgrade a 1.5 to 2.x once
without any extra work as far as I can remember.

>
>
> Thanks,
>
>
>
> Dan Slack
>
>



-- 
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
Boston - 1 Broadway, Cambridge, MA 02142

US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466
www.onehippo.com

Mime
View raw message