jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rama Kesara" <RKes...@art.com>
Subject DbFileSystem in repository.xml
Date Thu, 27 Oct 2011 19:38:51 GMT
I am seeing that everytime I restart my server, it is taking close to
3-4 minutes for initiation if I configure my fileSystem as DbFileSystem.

 

1)       Is there something that can be configured to skip scanning of
existing tables or probably recreation of tables everytime I start the
server?

2)      Is there something that we can configure to speedup this
process? From the configuration below, anyone see outstanding issues
that might create a performance overhead during server startup.

 

I am using following combinations:

 

<Repository>

                <FileSystem
class="org.apache.jackrabbit.core.fs.db.MSSqlFileSystem">

                                <param name="url"
value="jdbc:sqlserver://localhost:1433;databaseName=dHippoCMS" />

                                <param name="user" value="user1" />

                                <param name="password" value="pass1" />

                                <param name="schemaObjectPrefix"
value="repository_" />

                                <param name="schema" value="mssql" />

                </FileSystem>

                <Security appName="Jackrabbit">

                                <SecurityManager
class="org.hippoecm.repository.security.SecurityManager" />

                                <AccessManager
class="org.hippoecm.repository.security.HippoAccessManager" />

                                <LoginModule
class="org.hippoecm.repository.security.HippoLoginModule" />

                </Security>

                <Workspaces rootPath="${rep.home}/workspaces"
defaultWorkspace="default" />

                <Workspace name="${wsp.name}">

                                <FileSystem
class="org.apache.jackrabbit.core.fs.db.MSSqlFileSystem">

                                                <param name="url"
value="jdbc:sqlserver://localhost:1433;databaseName=dHippoCMS" />

                                                <param name="user"
value="user1" />

                                                <param name="password"
value="pass1" />

                                                <param
name="schemaObjectPrefix" value="${wsp.name}_" />

                                                <param name="schema"
value="mssql" />

                                </FileSystem>

                                <PersistenceManager
class="org.apache.jackrabbit.core.persistence.pool.MSSqlPersistenceManag
er">

                                                <param name="driver"
value="com.microsoft.sqlserver.jdbc.SQLServerDriver" />

<param name="url"
value="jdbc:sqlserver://localhost:1433;databaseName=dHippoCMS" />

                                                <param name="user"
value="user1" />

                                                <param name="password"
value="pass1" />

                                                <param
name="schemaObjectPrefix" value="${wsp.name}_" />

                                                <param
name="externalBLOBs" value="true" />

                                                <param
name="consistencyCheck" value="true" />

                                                <param
name="consistencyFix" value="true" />

                                </PersistenceManager>

                                ...

                </Workspace>

                ... SAME CONFIG FOR VERSION..

                <DataStore
class="org.apache.jackrabbit.core.data.db.DbDataStore">

                                <param name="driver"
value="com.microsoft.sqlserver.jdbc.SQLServerDriver" />

                                <param name="url"
value="jdbc:sqlserver://localhost:1433;databaseName=dHippoCMS" />

                                <param name="user" value="user1" />

                                <param name="password" value="pass1" />

                                <param name="databaseType"
value="sqlserver" />

                                <param name="minRecordLength"
value="1024" />

                                <param name="maxConnections" value="5"
/>

                                <param name="copyWhenReading"
value="true" />

                                <param name="tablePrefix" value="" />

                                <param name="schemaObjectPrefix"
value="" />

                </DataStore>

                

                <Cluster id="node1" syncDelay="2000">

                  <Journal
class="org.apache.jackrabbit.core.journal.MSSqlDatabaseJournal">

                                <param name="revision"
value="${rep.home}/revision.log" />

                                <param name="driver"
value="com.microsoft.sqlserver.jdbc.SQLServerDriver" />

                                <param name="url"
value="jdbc:sqlserver://localhost:1433;databaseName=dHippoCMS " />

                                <param name="user" value="user1" />

                                <param name="password" value="pass1" />

                  </Journal>

                </Cluster>          

</Repository>

 

Thanks for any help in advance.

 

Thanks,

Rama Kesara 

Software Engineer

Art.com

Phone: (510) 879-4831

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message