jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Slack" <dsl...@langui.com>
Subject Jackrabbit upgrade from 1.6 to 2.x problem
Date Fri, 14 Oct 2011 16:20:13 GMT
Hi all,

 

For one of our projects, I've decided to upgrade Jackrabbit from 1.6.0 to
2.3.0.  I may end up reverting back, just because I am using the RMI
interface, however, that remains to be seen.  Anyways, from reading the
documentation, it appears that the RMI interface for 2.0 will only work for
a "2.0" repository.  So, I was going to use the RepositoryCopier to see if I
can migrate my repository over.

 

However, when I attempt to create a 2.x Repository instance using my
existing repository, it fails when attempting to create the version manager.
When its attempting to check if the Node exists, it throws an exception:

 

org.apache.jackrabbit.core.state.ItemStateException: failed to read bundle:
deadbeef-face-babe-cafe-babecafebabe: java.lang.IllegalArgumentException:
Invalid namespace index: 6086317

 

I'm not really sure why this is the case, as I assumed the repository was
backwards compatible between 1.6 and 2.x.  Is there something I'm missing?

 

Thanks,

 

Dan Slack


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message