jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francisco Carriedo Scher <fcarrie...@gmail.com>
Subject Re: Setting up Access Control
Date Wed, 14 Sep 2011 15:23:21 GMT
Finally updating the repository.xml file as you suggested worked fine!!!
(the ACL is assigned with no exception so far). I will try now to complete
my tests (achieve allowing reading / writing to some users on some nodes,
deny both to others...). I tried trivial tests, such as creating a folder as
admin, setting the ACL for full access to admin and trying to delete the
folder as anonymous (access control works and prevents it!!!). I will start
working now to know how to create users and establish different privileges
and so on, but this is another history.

I do not know if i can update the Wiki pages but if i can contribute do not
hesitate to tell me, because there is no advice about the repository.xml
content (Default instead of SimpleAccessControlManager) and it results to be
key to get the access control working. I have not found any advice in Wiki
(the updated section yesterday, despite being a great quick start guide),
neither accurate answer in mailing list (i checked back just until May 2010)
and jackrabbit-standalone-2.2.8.jar creates the repository.xml file as i
posted some mails ago. I think it would save much time to future users.

I would like to contribute back so if you consider i can complete the Wiki
page related to access control do not hesitate to tell me!

Thanks four your attention!



2011/9/14 Alexander Klimetschek <aklimets@adobe.com>

> On 14.09.11 11:06, "Francisco Carriedo Scher" <fcarriedos@gmail.com>
> wrote:
>
>             // else node already has a policy, get that one
>             *acl = (AccessControlList) aMgr.getPolicies(path)[0];*
>
> Executing the code above i get  the following exception (caused by the code
> above highlighted in red colour):
> *
> java.lang.ArrayIndexOutOfBoundsException: 0*
>
>
> Yes, this means getPolicies() returns an empty array, and that is probably
> the case when using the SimpleAccessManager.
>
>         <SecurityManager
> class="org.apache.jackrabbit.core.security.simple.SimpleSecurityManager"
> workspaceName="security">
>
>
> This is not the 2.x default configuration… this should be the
> DefaultSecurityManager. See [0]. Where did you get your repository.xml from?
>
>         <LoginModule
> class="org.apache.jackrabbit.core.security.simple.SimpleLoginModule">
>
>
> Same, here, you want the DefaultLoginModule.
>
> [0]
> http://svn.apache.org/repos/asf/jackrabbit/trunk/jackrabbit-core/src/main/resources/org/apache/jackrabbit/core/repository.xml
>
> Regards,
> Alex
>
> --
> Alexander Klimetschek
> Developer // Adobe (Day) // Berlin - Basel
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message