jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Henderson <a...@devdefined.com>
Subject JCR browser that works with the latest version of Jackrabbit?
Date Sun, 12 Jun 2011 07:44:27 GMT
Hi All,

Is there anywhere I can get a version of a tool like the JCR browser that
will work correctly against a remote Jackrabbit 2.2.7 instance?

I did manage to download and connect using to my standalone instance using
the "JCR Browser" off sourceforge - (had to use the "HTTP" connection
method, but unforutnately it doesn't seem to be able to deserialize any of
the property values in the workspace I'm examining, which is using MySql
persistence - whenever I fetch the value of a property for a node, I get
this error:

Could not get the String-Value of the property => *java.rmi.UnmarshalException:
error unmarshalling return; nested exception is:
**java.io.InvalidClassException:
org.apache.jackrabbit.rmi.value.ReferenceValue; local class incompatible:
stream classdesc serialVersionUID = 5245358709465803351, local class
serialVersionUID = -3160494922729580458*
*
*
Which I'm guessing is because the JCR Browser is using the v1.5 jackrabbit
jars.

I tried updating the jars by copying in the new files and updating manifests
etc. - but this just broke the JCR browser completely.

Since then I've also tried the JCR Controller, and jrviewer - but neither of
these seemed to work at all.

I'm a total jackrabbit newbie - so being able to visualize the set of data
I'm having to work against (from a 3rd party tool) would be really helpful.

Cheers,

Alex

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message