jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shah, Sumit (CGI Federal)" <Sumit.S...@cgifederal.com>
Subject NPE: ConcurrentCache
Date Sun, 19 Jun 2011 05:31:32 GMT
All,

I am getting the following exception when trying to add anode. It goes from being sporadic
to consistent back to sporadic.

java.lang.NullPointerException
        at org.apache.jackrabbit.core.cache.ConcurrentCache$E.access$000(ConcurrentCache.java:47)
        at org.apache.jackrabbit.core.cache.ConcurrentCache$1.removeEldestEntry(ConcurrentCache.java:70)
        at java.util.LinkedHashMap.putImpl(LinkedHashMap.java:409)
        at java.util.LinkedHashMap.put(LinkedHashMap.java:370)
        at org.apache.jackrabbit.core.cache.ConcurrentCache.put(ConcurrentCache.java:168)
        at org.apache.jackrabbit.core.state.MLRUItemStateCache.cache(MLRUItemStateCache.java:83)
        at org.apache.jackrabbit.core.state.ItemStateReferenceCache.cache(ItemStateReferenceCache.java:169)

I researched this error a little bit, it seems like the exact same issue was reported as a
Jackrabbit bug [1], which was attributed to a version of the IBM JDK. Apparently it is a bug
with the IBM JDK [2]. Although the IBM bug says it affects Websphere users, but it's a bug
with their JDK and I am inclined to think it would affect all users of that version of the
IBM JDK.

We are running Jackrabbit 2.2.5 deployed in Weblogic running on AIX with IBM JDK. I would
appreciate if someone knows more details or could suggest a workaround/resolution.

Thanks
Sumit

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message