jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Javier Arias <jar...@ujaen.es>
Subject Re: New information about my last email...
Date Mon, 17 Jan 2011 16:25:21 GMT
Hi Alexander,


The situation is the follow: I want to change the admin password because
admin/admin is not secure. After that I want to create a new user who I
will use to add files to the server and to acces to the server.

I have achieved change admin password and create a new user.  I can
loggin in the server if I do it from Java code. If a try it from browser
(for example, Mozilla using url: http//localhost:8080), I only can
looggin using admin/admin. This is a problem because is someone connect
to my machine in port 8080, he can read all files content the
repository.

Another ask is, how can I give privileges to a new user for add files to
the repository?

In the repository.xmlI am using  DefaultLogin and DeafultAccess

Thank you. Regards.

El lun, 17-01-2011 a las 13:47 +0000, Alexander Klimetschek escribió:
> On 17.01.11 12:04, "Javier Arias" <jarias@ujaen.es> wrote:
> 
> >About the last email, I have copied a repository.xml that I had saved in
> >another folder. And now I can execute my code and I do not have problem
> >with userManager. 
> >
> >But the behaviour of the server is strange. I have changed the admin
> >password, now the password is admin2. If I login from java code, I must
> >type, username = "admin" and password = "admin2". If I loggin from
> >browser I must type username = "admin" and password = "admin2", this is
> >very strange!!
> 
> These two combinations are exactly the same - I guess you have a typo in
> there. Which login does not work or requires different credentials? And
> also, what browser login do you mean? Using Jackrabbit's webdav?
> 
> Regards,
> Alex
> 


 


Mime
View raw message