jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aimran <aimra...@gmail.com>
Subject Re: Import export fails for authorizable node
Date Thu, 06 Jan 2011 15:57:09 GMT

Angela, thanks for your reply.

I added the <import> fragment in under the <workspace> element, but I still
get the same error: "..mandatory property {internal}password does not
exist.."

Here's some more info, in case I am doing something wrong:
- Using UserPerWorkspaceSecurityManager SecurityManager
- Running a Jackrabbit 2.1.2 transient repository over derby
- Created a workspace and added a new user in the workspace with UserManager
api
- Added some content
- Set access control  on the added content for the new User
- Exported the workspace XML with the session API [logged in as Admin]. The
exported XML dump shows the new user, content and the ACL
- Importing into another repository that already has the workspace
pre-created, but is empty. Also the config file has the import setting
provided by Angela. This is where it bombs. 
-- Tried to export/import from root path "/":FAILS.mandatory property
password... exception
-- Tried to export/import just the "/rep:security": FAILS. Creates a second
security node [ /rep:security[2]/rep:authorizab...] instead on overriding
the current one and also thows the "mandatory property..." exception.
-- If I import export just the application content it imports, but all the
ACL settings are lost.


What else should I be doing? Can someone please provide some clear steps on
how to go about exporting and import all data relevant to a workspace?


Some other confusion points that I have:
- Since export/import is per workspace basis and access
control+security+system data is stored above/outside the work space level
[right?], then how exactly is the other information supposed to be
exported/imported.
- Since export/import doesnt support versions and other system data, what
exactly is the purpose/motivation behind the import export API. IMHO, it
doesnt seem to provide any value as the import/export doesnt keep the two
workspaces in sync. What is its use case?

-- 
View this message in context: http://jackrabbit.510166.n4.nabble.com/Import-export-fails-for-authorizable-node-tp3176272p3177654.html
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.

Mime
View raw message