jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yusuf Aaji <yusuf.a...@gmail.com>
Subject Day Eclipse Plugin with Jackrabbit 2.1.2
Date Mon, 13 Dec 2010 08:21:29 GMT
Hi,

I have downloaded the JCR eclipse plugin from Day Software and I'm trying to
connect to a Jackrabbit 2.1.2 repository but without any success so far.

I have jackrabbit deployed as jboss jca, I deployed the jackrabbit-jcr-rmi
and I was able to connect to the repositor remotly using this code

        Hashtable<String, String> env = new Hashtable<String, String>();
        env.put(Context.INITIAL_CONTEXT_FACTORY,
"org.jnp.interfaces.NamingContextFactory");
        env.put(Context.PROVIDER_URL, "jnp://localhost:1099");
        env.put(Context.URL_PKG_PREFIXES,
"org.jboss.naming:org.jnp.interfaces");


        InitialContext ctx = new InitialContext(env);

        ClientAdapterFactory adapter = new ClientAdapterFactory();
        RemoteRepository rr;
        rr = (RemoteRepository)
ctx.lookup("jnp://localhost:1099/jcrServer");
        Repository repository = adapter.getRepository(rr);
        Credentials credJBoss = new SimpleCredentials("yaaji",
"***".toCharArray());
        Session session = repository.login(credJBoss);

        NodeIterator nodes = session.getRootNode().getNodes();
        while( nodes.hasNext()){
            Node node = nodes.nextNode();
            System.out.println( node.getPath() );
        }

so I guess the RMI is working fine.

I tried to configure a remote repository using the plugin and I put
//localhost:1099/jcrServer in RMI URL field with RMI Accessor 1.4
with proper username and password. Next is disabled and clicking Finish does
nothing, Clicking browse for workspaces give java.rmi.ConnectIOException:
non-JRMP server at endpoint.

using //localhost:1098/jcrServer as the url gives
java.rmi.NoSuchObjectException: no such object in table

I tried different versions of jackrabbit-jcr-rmi 2.0, 1.4, 1.3 without any
success.

any idea how to get this plugin working?!!

regards,
Yusuf

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message