jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wouter Boers <wou...@ikke.net>
Subject Re: AW: Can't open files
Date Wed, 01 Dec 2010 14:11:45 GMT
Hi Mario,

Jaas would be nice to have. Webdav can only use digest or basic authentication. Having a 'real'
 user makes is easier to set-up access rights, The problem you have is not a Jackrabbit problem
but a MS issue. 

Unless you use sharepoint, the office stack by definition does not allow you to open files
in read/write mode on a webdav server. You need to adjust the registry settings for that.
 The fix depends on the office version you use. 

Windows Registry Editor Version 5.00

; Created by Wouter Boers - Ogle
; Ogle NV - Nooderdereinde 311 - 1243JX 's Graveland
; http://www.ogle.nl
; See http://support.microsoft.com/kb/870853 and http://blogs.sharepointhosting.com/Lists/Posts/Post.aspx?List=399ed944%2D72d2%2D4932%2Dbc13%2Dde0586abf2d1&ID=75

[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Internet]
"OpenDocumentsReadWriteWhileBrowsing"=dword:00000001


Regards, Wouter
On 1 dec 2010, at 13:03, Mario Killmer wrote:

> Hello again,
> 
> that's make me crazy ! Maybe some of you can point me to the right
> direction.
> 
> I try to open an word document in read-write mode from a windows webdav
> client (explorer). But when I click on the files in the webfolder nothing
> happens. And I don't know where my problem is !
> I use the simplewebdavservlet and the default repository (with user
> anonymus) from the jackrabbit.war archive. Is the anonymus user the problem
> ? How can I setup a new user for testing my issues ? Must I define a jaas
> authentification ? Or is there an easier way to define a user with
> read/write permissions ?
> 
> Regards,
> Mario
> 
> -----Urspr√ľngliche Nachricht-----
> Von: Alexander Klimetschek [mailto:aklimets@adobe.com] 
> Gesendet: Dienstag, 30. November 2010 21:46
> An: users@jackrabbit.apache.org
> Betreff: Re: Can't open files
> 
> On 30.11.10 21:34, "Mario Killmer" <info@mk-webservices.de> wrote:
> 
>> Hello Alex,
>> thanks for your response. After many hours more in the internet I find 
>> an new point. Can it be an issue regarding to the anonymus user in 
>> jackrabbit? Because the anonymus user has only read permissions.
>> Can that be the Problem ?
> 
> Yes, didn't think about that ;-)
> 
> You need to login with a user with the appropriate rights when setting up
> the webdav connection in Windows.
> 
> Regards,
> Alex
> 
> --
> Alexander Klimetschek
> Developer // Adobe (Day) // Berlin - Basel
> 
> 
> 
> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message