jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Abley <james.ab...@gmail.com>
Subject Re: Unable to commit volatile index
Date Tue, 07 Sep 2010 13:12:07 GMT
On 7 September 2010 08:06, zeeman <zeeman@zeeman.de> wrote:

> Hi!
>
> > There is one index at repository level and multiple indexes at each
> > workspace level. The one you are looking at is repository index and it
> > doesn't change much. I don't know what exactly is stored in repository
> > index. My guess is it will hold indexes for global info like node types
> or
> > possibly root node?
> >> as additional info, i took a deeper look on the mentioned
> >> file/directory:
> >> > org.apache.jackrabbit.core.query.lucene.MultiIndex] -[-] (Timer-1:)
> >> Unable to commit volatile index
> >> > java.io.IOException: Cannot delete
> X:\jackrabbit\repository\index\indexes
>
> I was able to reproduce this issue by locking a indexes file (I tested
> with default workspace indexes because it's easier to cause changes in
> the JCR there).
> I just locked it by a simple file lock and caused a change in the JCR.
> The issue was logged in a loop while the lock on the file exists.
> As soon as the lock was released jackrabbit could update the indexes
> file and the logging of that stacktrace stoped.
>
> Though we fixed it by restarting the server (not only JBoss, the whole
> machine) as we had no idea how to monitor open files on a windows
> machine (something like lsof...)
>

Been a _long_ time since I worked on Windows, but IIRC, this was always very
helpful for stuff like that.

http://technet.microsoft.com/en-us/sysinternals/default.aspx

Cheers,

James

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message