jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Narendra Sharma <narendra.sha...@gmail.com>
Subject Re: Unable to commit volatile index
Date Mon, 06 Sep 2010 23:11:14 GMT
I believe the SearchIndex config snippet that you provided corresponds to
workspace. I think the value in following path parameter should use
"wsp.home" instead of "rep.home/repository". Try out after changing this.

<param name="path" value="${rep.home}/repository/index" />

Thanks,
Naren

On Mon, Sep 6, 2010 at 3:36 AM, zeeman <zeeman@zeeman.de> wrote:

> Hi!
>
> I try to use jackrabbit in a clustered setup.
>
> Now I'm facing this errors:
>
> org.apache.jackrabbit.core.query.lucene.MultiIndex] -[-] (Timer-1:) Unable
> to commit volatile index
> java.io.IOException: Cannot delete X:\jackrabbit\repository\index\indexes
>        at
> org.apache.lucene.store.FSDirectory.deleteFile(FSDirectory.java:363)
>        at
> org.apache.jackrabbit.core.query.lucene.IndexInfos.write(IndexInfos.java:139)
>        at
> org.apache.jackrabbit.core.query.lucene.MultiIndex.flush(MultiIndex.java:911)
>        at
> org.apache.jackrabbit.core.query.lucene.MultiIndex.checkFlush(MultiIndex.java:1164)
>        at
> org.apache.jackrabbit.core.query.lucene.MultiIndex.access$100(MultiIndex.java:80)
>        at
> org.apache.jackrabbit.core.query.lucene.MultiIndex$1.run(MultiIndex.java:317)
>        at java.util.TimerThread.mainLoop(Timer.java:512)
>        at java.util.TimerThread.run(Timer.java:462)
>
> I'm using Jackrabbit 1.6.3 with Sun JDK 1.6.0_11
> It is deployed on a JBoss 4.3.2 as JCA connector.
>
> The cluster is configured to use (there is only the default workspace)
> * OracleFileSystem as repostiorie's filesystem
> * OracleFileSystem as workspace's filesystem
> * OraclePersistenceManager as workspace's persistence manager
> * OracleFileSystem for versioning
> * OracleDatabaseJournal for the node journal
> (If required I can attache the complete configuration)
>
> The SearchIndexes (as I suspect the problem with them) look like
>        <SearchIndex
> class="org.apache.jackrabbit.core.query.lucene.SearchIndex">
>                <param name="path" value="${rep.home}/repository/index" />
>                <param name="textFilterClasses"
> value="org.apache.jackrabbit.extractor.HTMLTextExtractor,org.apache.jackrabbit.extractor.XMLTextExtractor"
> />
>                <param name="extractorPoolSize " value="2" />
>                <param name="supportHighlighting" value="true" />
>        </SearchIndex>
>
> Does anyone have an idea why this error occurs?
> I suspect its not a security issues because the message would look
> different, nor?
> The stacktrace is reappearing every second.
>
> Thanks in advance,
> Sebastian
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message