jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juan Diego Botiva Leon <juandbot...@hotmail.com>
Subject RE: Problems Migrating Cluster Data
Date Mon, 31 May 2010 17:30:46 GMT

Hi,

I'm using Jackrabbit 1.6.0 the following is the repository.xml file in the destination server.
When I imported the MySQL dump files I deleted the repository folder to get Jackrabbit to
regenerate the indexes again (so the workspace.xml file is regenerated also). We have the
journal database in a different machine, could this be the problem ? Thanks in advance for
all your help.

Regards.

<Repository>
    <Cluster id="jdbl" syncDelay="5000">
        <Journal class="org.apache.jackrabbit.core.journal.DatabaseJournal">
            <param name="revision" value="${rep.home}/revision.log" />
            <param name="driver" value="com.mysql.jdbc.Driver" />
            <param name="url" value="jdbc:mysql://localhost:3306/util?autoReconnect=true"
/>
            <param name="user" value="repo"/>
            <param name="password" value="repopwd"/>
        </Journal>
    </Cluster>
    <FileSystem class="org.apache.jackrabbit.core.fs.db.DbFileSystem">
        <param name="url" value="jdbc:mysql://localhost:3306/repository?autoReconnect=true"/>
        <param name="user" value="repo"/>
        <param name="password" value="repopwd"/>
        <param name="driver" value="com.mysql.jdbc.Driver"/>
        <param name="schema" value="mysql"/>
        <param name="schemaObjectPrefix" value="jcr_repository_fs_"/> 
    </FileSystem>
    <Security appName="Jackrabbit">
        <AccessManager class="org.apache.jackrabbit.core.security.SimpleAccessManager"/>
        <LoginModule class="org.apache.jackrabbit.core.security.SimpleLoginModule">
           <param name="anonymousId" value="anonymous"/>
           <param name="repo" value="superuser"/>
        </LoginModule>
    </Security>
    <Workspaces rootPath="${rep.home}/workspaces" defaultWorkspace="myRepo"/>
    <Workspace name="${wsp.name}">
        <FileSystem class="org.apache.jackrabbit.core.fs.db.DbFileSystem">
            <param name="url" value="jdbc:mysql://localhost:3306/repository?autoReconnect=true"/>
            <param name="user" value="repo"/>
            <param name="password" value="repopwd"/>
            <param name="driver" value="com.mysql.jdbc.Driver"/>
            <param name="schema" value="mysql"/>
            <param name="schemaObjectPrefix" value="jcr_${wsp.name}_fs_"/> 
        </FileSystem>
        <PersistenceManager class="org.apache.jackrabbit.core.persistence.bundle.MySqlPersistenceManager">
            <param name="url" value="jdbc:mysql://localhost:3306/repository?autoReconnect=true"/>
            <param name="user" value="repo"/>
            <param name="password" value="repopwd"/>
            <param name="driver" value="com.mysql.jdbc.Driver"/>
            <param name="schemaObjectPrefix" value="jcr_${wsp.name}_pm_"/> 
            <param name="externalBLOBs" value="false"/>
        </PersistenceManager>
        <SearchIndex class="org.apache.jackrabbit.core.query.lucene.SearchIndex">
            <param name="path" value="${wsp.home}/index"/>
            <param name="indexingConfiguration" value="index-config.xml"/>
            <param name="textFilterClasses" value="org.apache.jackrabbit.extractor.MsWordTextExtractor,org.apache.jackrabbit.extractor.MsExcelTextExtractor,org.apache.jackrabbit.extractor.MsPowerPointTextExtractor,org.apache.jackrabbit.extractor.PdfTextExtractor,org.apache.jackrabbit.extractor.OpenOfficeTextExtractor,org.apache.jackrabbit.extractor.RTFTextExtractor,org.apache.jackrabbit.extractor.HTMLTextExtractor,org.apache.jackrabbit.extractor.XMLTextExtractor"/>
            <param name="extractorPoolSize" value="2"/>
            <param name="extractorTimeout" value="5000"/>
        </SearchIndex>
    </Workspace>
    <Versioning rootPath="${rep.home}/version">
        <FileSystem class="org.apache.jackrabbit.core.fs.db.DbFileSystem">
            <param name="url" value="jdbc:mysql://localhost:3306/repository?autoReconnect=true"/>
            <param name="user" value="repo"/>
            <param name="password" value="repopwd"/>
            <param name="driver" value="com.mysql.jdbc.Driver"/>
            <param name="schema" value="mysql"/>
            <param name="schemaObjectPrefix" value="jcr_version_fs_"/> 
        </FileSystem>
        <PersistenceManager class="org.apache.jackrabbit.core.persistence.bundle.MySqlPersistenceManager">
            <param name="url" value="jdbc:mysql://localhost:3306/repository?autoReconnect=true"/>
            <param name="user" value="repo"/>
            <param name="password" value="repopwd"/>
            <param name="driver" value="com.mysql.jdbc.Driver"/>
            <param name="schemaObjectPrefix" value="jcr_version_pm_"/> 
            <param name="externalBLOBs" value="false"/>
        </PersistenceManager>
    </Versioning>
</Repository>


> Date: Mon, 31 May 2010 09:16:05 +0200
> Subject: Re: Problems Migrating Cluster Data
> From: thomas.mueller@day.com
> To: users@jackrabbit.apache.org
> 
> Hi,
> 
> This sounds like a configuration problem. If you change the
> persistence location, please ensure you change the repository.xml as
> well as all workspace.xml files.
> 
> See also see http://wiki.apache.org/jackrabbit/Clustering
> 
> If the problem persists please post the configuration (all
> repository.xml and workspace.xml files). We also need to know the
> versions of the jackrabbit jar files you use.
> 
> Regards,
> Thomas
 		 	   		  
_________________________________________________________________
Hotmail is redefining busy with tools for the New Busy. Get more from your inbox.
http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_2
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message