jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Müller <thomas.muel...@day.com>
Subject Re: Program blocks on setProperty() in Jackrabbit-webapp-2.0.0
Date Mon, 01 Mar 2010 14:56:08 GMT
Hi,

Could you create a full thread dump and post it? To create one, press
Ctrl+Pause (Windows) or use jsp -l / jstack <pid> / kill -QUIT <pid>

Regards,
Thomas


On Mon, Mar 1, 2010 at 3:52 PM, Robert Eichinger
<robert.eichinger.re@googlemail.com> wrote:
> Hi,
>
> I recently started developing an application that has to keep track of
> a large amount of images. I started using Jackrabbit 2.0.0 (webapp)
> and I am using PostgreSQL as Database backend. The repository is being
> accessed via jackrabbit-rmi. For small images (<50 kb) the whole
> system works fine, but when I want to put bigger images into the
> repository, the call to Node.setProperty() does not return and the
> whole application hangs. A small extract of my source code:
>
> Node imageNode = aidNode.addNode(id,"nt:file");
> Node addInfoNode = imageNode.addNode("jcr:content","nt:resource");
> addInfoNode.setProperty("jcr:mimeType", mimeType);
> lastModified.setTimeInMillis(file.lastModified());
> addInfoNode.setProperty("jcr:lastModified", lastModified);
> Binary binImage = vf.createBinary(fis);
> addInfoNode.setProperty("jcr:data",binaryImage);
> session.save();
>
> I  tried different ways of solving the problem with jackrabbit 2.0.0
> but none of them succeeded (MySQL as backend, FS as backend, using
> deprecated method Node.setProperty(String name, InputStream)). Then I
> tried jackrabbit 1.6 and it works perfectly for small and large
> images.
>
> My questions now are:
> Did I configure something wrong?
> Did I forget to add a mixin that is required by jackrabbit 2.0.0 or JCR 2.0?
> Is my way the correct way to store binary data in jackrabbit?
>
> Thanks in advance,
> Robert
>

Mime
View raw message