jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross McDonald <rossaj...@yahoo.co.uk>
Subject Exception using Jackrabbit 2.0.0
Date Wed, 24 Mar 2010 09:45:16 GMT

Hi Guys.
 
I am using a component as part of a publishing plugin.  It uses Jacrabbit
for its repository.

My component is basically copying the contents of one workspace to another.

When I publish from development to staging it works, but I get a massive
stacktrace in the terminal: 

ERROR - BundleDbPersistenceManager - failed to check existence of node 
references: c6681b77-e4a5-4027-9d20-b53db5819964 
java.sql.SQLException: The conglomerate (1,056) requested does not 
exist. 
        at 
org.apache.derby.impl.jdbc.SQLExceptionFactory40.getSQLException(Unknown 
Source) 
        at org.apache.derby.impl.jdbc.Util.generateCsSQLException(Unknown 
Source) 
        at 
org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unkno
wn 
Source) 
        at 
org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown 
Source) 
        at
org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown 
Source) 
        at
org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown 
Source) 
        at org.apache.derby.impl.jdbc.EmbedPreparedStatement.<init>(Unknown 
Source) 
        at
org.apache.derby.impl.jdbc.EmbedPreparedStatement20.<init>(Unknown 
Source) 
        at
org.apache.derby.impl.jdbc.EmbedPreparedStatement30.<init>(Unknown 
Source) 
        at
org.apache.derby.impl.jdbc.EmbedPreparedStatement40.<init>(Unknown 
Source) 
        at org.apache.derby.jdbc.Driver40.newEmbedPreparedStatement(Unknown 
Source) 
        at 
org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown 
Source) 
        at 
org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown 
Source) 
        at 
org.apache.jackrabbit.core.persistence.bundle.ConnectionRecoveryManager.exe
cuteStmtInternal(ConnectionRecoveryManager.java: 
293)
 
When I then try to publish from staging to production is does not copy,
production is left untouched, presumably because of the stacktrace in the
first copy.  Could this be because of some kind of issue the repository is
having with the content.  As it happens the content of the workspace is a
relatively simple HTML website, some images, come css and a .ogg movie. 

Any ideas? 

Thanks for your help, 

 -- Ross 
-- 
View this message in context: http://n4.nabble.com/Exception-using-Jackrabbit-2-0-0-tp1680288p1680288.html
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.

Mime
View raw message