jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bram de Kruijff <Bram.deKrui...@gxsoftware.com>
Subject Corrupt session and persistent state
Date Fri, 19 Feb 2010 10:49:56 GMT
Hi all,

Recently I came across some strange cases of inconsistent persistent state. Most of the time
it seems that nodes deserialized from bundles have (parent/child or cross) references to non
existing bundles/nodes. The problem is typically shown by NoSuchItemStateException that can
in some cases even prevent the repository from starting when for example it fails to boostrap
an index.

It has proven very difficult to reproduce this problem, but I think I have a scenario that
does show such a problem after a ReferentialIntegrityException has occurred on a session.
To demonstrate it I created a jira issue with an attached fix @ https://issues.apache.org/jira/browse/JCR-2503


I ran this against 1.5, 1.6 with the same result. The trunk also shows and exception but at
a different point in the test. Can someone please confirm/verify this and/or explain to me
what I might be doing wrong?

Thanks & Regards,
Bram





Mime
View raw message